Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My current task is to configure a testing virtual machine to join our company's AD domain, so users can login with domain credentials.

I am only responsible to make tests with that VM, that will be used as a sandbox for migrating some company services to a better-performing infrastructure, for example SVN (upgrading our CVS repo) and an internal wiki.

I am not an Administrator of the AD controller, and my boss explicitly said that everything I do with the test machine, which is under the control of a common employee, must be done without having access to the great power of Administrator login.

I installed openSUSE 13.1 from SuSE Studio, logged in as root and tried to follow a tutorial to join the VM to the domain.

The problem is that the tutorial supposes the Linux user has Administrator credentials for AD controller, which is not the case. I have my own credentials, but I'm not an admin. And I must complete the procedure without admin credentials (our IT person might configure a "production" machine based on my configuration only after the demo gets approved).

I remember that

during my last job I needed no Admin credentials to join an AD domain with Windows 7. I simply used my own credentials when requested, and any coworker could log in with his/her own credentials.

What I tried so far:

Using YaST, I entered Windows Domain Membership, typed the domain name DOMAIN.IT in the Domain or Workgroup

YaST AD

When I was asked to join the domain, I chose YES, then entered my own domain credentials and left Machine Account OU default.

YaST AD

I rebooted the system with init 6 and the time for login came. First, let me say that in Linux I have typed DOMAIN.IT as domain, but in Windows machines we do use DOMAIN\name.surname accounts (case insensitive).

With XShell SSH client, I tried the following usernames with the right password:

  • name.surname
  • domain\name.surname
  • domain.it\name.surname
  • DOMAIN\name.surname
  • DOMAIN.IT\name.surname

All failed.

How do I log in correctly after YaST said I'm a member of the domain?

share|improve this question
up vote 1 down vote accepted

I learnt that the correct and complete answer is no necessary the following:

In YaST's User & Group Manager I enabled LDAP/AD login, which was disabled earlier. Then I have set up NTP synchronization with our local NTP source.

But in the Windows world it is a universal constant that either any user can join a computer to the network, and then LDAP configuration in Linux can ben performed, or the user must be granted authority to join machines to AD (for example, be group of a support staff).

Otherwise this cannot be done without Administrator credentials.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .