Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get IPv6 to work.
My host provied me the following informations:
IPv6 network: 2a03:4000:2:483::/64
IPv6 gateway: fe80::1

My /etc/network/interfaces looks like this:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

#IPV6 static configuration
iface eth0 inet6 static
pre-up modprobe ipv6
address 2a03:4000:2:483::2
netmask 64
gateway fe80::1
# END IPV6 configuration


And ifconfig outputs the following:

eth0      Link encap:Ethernet  HWaddr 52:54:7e:5a:c2:b4
          inet addr:46.38.236.169  Bcast:46.38.239.255  Mask:255.255.248.0
          inet6 addr: fe80::5054:7eff:fe5a:c2b4/64 Scope:Link
          inet6 addr: 2a03:4000:2:483::2/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:173542 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27863 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:10582552 (10.0 MiB)  TX bytes:1658598 (1.5 MiB)


ip -6 route show outputs:

default via fe80::1 dev eth0  metric 1024


And route -6:

Kernel IPv6 routing table
Destination                    Next Hop                   Flag Met Ref Use If
2a03:4000:2:483::/64           ::                         U    256 0     0 eth0
fe80::/64                      ::                         U    256 0     0 eth0
::/0                           fe80::1                    UG   1024 0     0 eth0
::/0                           ::                         !n   -1  1    50 lo
::1/128                        ::                         Un   0   1    25 lo
2a03:4000:2:483::2/128         ::                         Un   0   1    15 lo
fe80::5054:7eff:fe5a:c2b4/128  ::                         Un   0   1     0 lo
ff00::/8                       ::                         U    256 0     0 eth0
::/0                           ::                         !n   -1  1    50 lo


ping6 ipv6.google.com results in

PING ipv6.google.com(muc03s08-in-x04.1e100.net) 56 data bytes
From 2a03:4000:2:483::2 icmp_seq=1 Destination unreachable: Address unreachable
From 2a03:4000:2:483::2 icmp_seq=2 Destination unreachable: Address unreachable
From 2a03:4000:2:483::2 icmp_seq=3 Destination unreachable: Address unreachable
--- ipv6.google.com ping statistics ---
4 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2999ms

The server is running Debian 3.2.51-1. I hope you can help me with this.

share|improve this question
    
try ping6 ipv6.google.com%eth0 sometimes being explicit helps. Aside from that this GW address fe80::1 seems a bit strange. this range has been set aside for link local addresses and should not be used for GW stuff. – zeridon Feb 7 '14 at 12:43
    
@zeridon: link-local addresses are very often used for gateways. That is one of its purposes. Take a look at a machine that got its default GW from a Router Advertisement. It will be a link-local address, and it will work just fine. – Sander Steffann Feb 7 '14 at 13:11
    
@Kimmax: Check your firewall settings. I wouldn't be surprised if your (default?) firewall is blocking IPv6 traffic. Note that for IPv6 you have to use ip6tables instead of iptables – Sander Steffann Feb 7 '14 at 13:12
1  
link-local addresses are fine for gateways, but you still need to confirm that you have the right address for the gateway. Where is the router in all this? – Paul Feb 7 '14 at 13:25
    
I set up the ip6tables with help of this doc: madduck.net/docs/ipv6 Is this right? – Kimmax Feb 7 '14 at 13:32

You must log in to answer this question.

Browse other questions tagged .