Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm working on a kernel 2.4-based OS that normally runs on hardware, but now we're porting it to VMWare. I'm having trouble with access to the hard disk. There are no problems running on hardware, only on VMWare.

I'm getting "EXT3-fs: unable to read superblock" in the following two scenarios:

  1. On booting for the first time, or
  2. If formatting the whole disk (not just a partition)

The strange thing about (2) is that the error occurs after reboot, not before. The user has limited access to the shell, and the partitioning/formatting is done by the code, so it's not a PEBKAC problem (unless it's me, the developer). The other strange thing about (2) is that, as far as I know, the kernel reads the partition table at boot time, so the problem shouldn't even be possible.

We're running the OS on VMWare Player 2.5.1 and for conversion using qemu-img, with input/output formats raw and vmdk, respectively.

What's the difference between a hardware HDD (which works fine) and a VMWare virtual HDD? What do I need to do in the code to not confuse the kernel?

share|improve this question

closed as off topic by Diago Nov 19 '09 at 5:40

Questions on Super User are expected to relate to computer software or computer hardware within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Which VMWare product are you using? ESX, ESXi, Server, Workstation, etc etc? How are you doing the conversion? P2V Converter? –  MDMarra Nov 16 '09 at 22:43
    
I'm running the OS on VMWare Player 2.5.1. For conversion we're using qemu-img, with input format "raw" and output format "vmdk". –  Paul Nov 16 '09 at 23:18

1 Answer 1

Turns out this has nothing to do with VMWare or Linux. After mucking around in the kernel and our custom partitioning/formatting tools, I discovered a build script was botching the whole thing.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.