Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install hstore in Postgres on Mac OSX 10.9, but I'm having major troubles with it. First I had some trouble getting psql to work after installing postgresql using brew, so I finally installed Postgres using postgresql.app. After that I logged into psql, created a database and tried creating the hstore extension using CREATE EXTENSION hstore;, which throws me an error saying ERROR: could not open extension control file "/usr/local/Cellar/postgresql/9.3.2/share/postgresql/extension/hstore.control": No such file or directory.

I guess that path refers to a brew install, which doesn't exist (I uninstalled the brew version). Would anybody know how I can still install the hstore extension now?

I'm rather lost here, so all tips are welcome!

share|improve this question
    
This question is copied & pasted from this Stack Overflow post: stackoverflow.com/q/21657212/398670 . Please don't clone your posts. I don't blame you for being lost, the OS X packaging situation for PostgreSQL is a horrible mess, with too many different packages floating around. Alas, the PostgreSQL project cannot force anyone to stop packaging PostgreSQL. –  Craig Ringer Feb 9 at 10:48

1 Answer 1

up vote 2 down vote accepted

You didn't actually uninstall the Brew version fully. The PostgreSQL you are connected to is using /usr/local/Cellar/postgresql/9.3.2/share/postgresql/ as $libdir, which is a Homebrew path.

I'd say you just unlinked it from /usr/local, you didn't really uninstall it, and it's still running quite happily.

Even if you actually deleted it, on Mac OS X (like most OSes except Windows) you can delete a file that's still open - so PostgreSQL can potentially be still running, even though the files have been deleted. The OS will really delete them when they are closed.

share|improve this answer
    
I thought that as well, but the folder /usr/local/Cellar/postgresql/ doesn't even exist, let alone anything below that. I guess that I really uninstalled the brew version of postgres. Or do you think it still exists after all? In that case, would you have any idea how to uninstall it? –  kramer65 Feb 9 at 11:11
    
btw: I tried a simple 'brew uninstall postgresql', but that results in Error: No such keg: /usr/local/Cellar/postgresql. Any ideas how I could uninstall it fully? –  kramer65 Feb 9 at 11:31
    
@kramer65 See edit. Reboot, kill the postgresql processes associated with that install, or use launchd to stop the deleted PostgreSQL instance. –  Craig Ringer Feb 9 at 11:31
    
Thanks! It was indeed still running. I killed it, started postgresql.app, and now i finally managed to install hbase. Thanks a million! –  kramer65 Feb 9 at 12:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.