Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having this weird problem with my Windows 8.1 that I'm unable to type-in @ £ $ symbols with my Swedish keyboard. I know the first probable answer would be to check my keyboard settings and correct it if necessary. However, I have checked/changed that setting 100 times but it didn't help.

To make this issue more interesting, I'm having the exact same settings on my other computer (with Swedish keyboard too) and there I'm able to type-in all those characters.

I'm using Microsoft Wireless Keyboard 800 (Model 1455). The problem still persists if I plugin some other wired keyboard with Swedish layout.

Is this a known bug in windows? and how to fix this?

For your perusal, I'm attaching the screenshot of my current settings.

enter image description here

share|improve this question

3 Answers 3

Try and install a Danish or German keyboard (you can delete them later) and see if you can produce those characters.

share|improve this answer
    
tried with danish, still no luck –  waqaslam Feb 15 '14 at 17:08
up vote 0 down vote accepted

After some intensive trouble-shooting (which even took me to perform a fresh install of my windows 8 operating system) I am finally able to resolve this problem.

The problem is actually one of the utility software that comes with my Gigabyte motherboard. Its called EasyTune available in App Center that controls the overclocking and system performance. Once the program is running or asked to retain its settings after boot, then it disables @£$ keys system-wide.

enter image description here

enter image description here

In my case, I enabled the option "Retain Smart Fan settings after reboot." in order to minimize the CPU-fan RPM as I'm using my computer as HTPC and want it to be quite,

Anyhow, disabling the auto-retain options or uninstalling this utility feature is a confirm solution in my case. I hope Gigabyte would release an update which should fix this annoying problem.

share|improve this answer

With a Swedish layout keyboard you will need to install the Swedish language pack. Click Add Language, Locate Swedish (Svenska), and click Move Up.

After you've done this, go to Advanced settings and scroll down to Switch input methods and check Use the desktop language bar when it's available (Last step not needed, you can also switch between English and Swedish layout with Alt + Shift.

The problem is that Swedish keyboards with an English Language installed will not allow you to use Alt Gr + <number> and thus make it hard to write special characters.

share|improve this answer
    
Compared to my other computer, I only have English language (with Swedish keyboard) installed and there's nothing i need to switch between input types in order to type those symbols. Another thing is, i'm able to type-in characters like { [ ] } which can only be entered using Alt Gr key. The only problem is with these characters @ £ $. –  waqaslam Feb 9 '14 at 19:18
    
Alt + Shit... *giggle* –  Svish Mar 5 at 15:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.