Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When the computer enters sleep it locks itself and I would like to avoid that. (Ubuntu 9.10)

Please don't upvote answers that don't work!

share|improve this question
add comment

4 Answers

Try:

Go System > Preferences > Screensaver and uncheck the box that says lock when screensaver is active.

Else

gconftool-2 --type boolean -s /apps/gnome-power-manager/lock_on_blank_screen false
gconftool-2 --type boolean -s /apps/gnome-power-manager/lock_use_screensaver_settings false

If these 2 don't work then

Open the terminal, and type gconf-editor In the window that comes up go to apps > gnome-power-manager > lock On the right, UNCHECK suspend and hibernate and make sure that the use_screensaver_settings is CHECKED

or -

In your terminal type sudo gedit /etc/default/acpi-support
Go to the line that says LOCK_SCREEN=true and put a # in front of it.

Close, save and try it out.

All solutions via UbuntuForums

share|improve this answer
2  
None of these worked... –  Tarnay Kálmán Nov 17 '09 at 4:42
2  
If you look at the seconds page of thread you linked, you will see that it didn't for the OP either... –  Tarnay Kálmán Nov 17 '09 at 4:47
3  
Indeed there is a bug filed for that: bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/… if you have an account on launchpad I would suggest you mark the bug as "affects me too" as this gives a chance to be noticed first. –  mac Nov 17 '09 at 15:01
2  
What's with the downvotes ? You asked for a way, I provided alternatives. If it doesn't work, go file a bug. If I did something wrong put a comment. –  Sathya Nov 20 '09 at 23:16
1  
I didn't downvote, but the answer below worked better than any of your alternatives, so I am tempted to downvote just to promote that answer. –  luqui Feb 21 '11 at 0:43
show 1 more comment

MoarningSun got it partially working: https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/255228

Credit to mac for finding the launchpad bug report, and cleaning it up some.

share|improve this answer
1  
See MoarningSun's update. It's pretty unreliable. –  Tarnay Kálmán Dec 10 '09 at 5:23
    
That's why I said partially. At least he found out part of what wasn't working. –  Peter Cordes Dec 10 '09 at 10:12
add comment

To disable the screen lock on suspend you must open a gconf-editor and disable the following options:

/apps/gnome-power-manager/lock_on_hibernate = false

/apps/gnome-power-manager/lock_on_suspend = false

/apps/gnome-power-manager/lock_on_blank_screen = false

However with this settings when you press the suspend butto you get no screensaver at all and therefore no visible feedback until the laptop is switched off. I solved this second problem by creating a /etc/acpi/suspend.d/06-gnome-screensaver.sh script which starts the gnome-screensaver at the beginning of the sleep sequence. Now I have screensaver on suspend but no screen lock dialog on resume.

It would be nice if gnome-power-manager would rename the current lock_on_* options to screensaver_on_* and add a new lock_screen option to decide if locking the screen or simply activating a screensaver.

share|improve this answer
    
Thanks, this one worked for me! –  luqui Feb 21 '11 at 0:43
    
Ubuntu 11.04, does not work –  YumYumYum Sep 7 '11 at 13:29
add comment

What works in 11.04 is to use

gconftool-2 --type boolean -s /apps/gnome-power-manager/lock/suspend false

you can also replace suspend with hibernate or blank_screen if you wish.

share|improve this answer
    
Ubuntu 11.04, does not work –  YumYumYum Sep 7 '11 at 13:25
add comment

protected by Diago Oct 13 '10 at 15:12

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.