Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A website displays "This page is asking you to confirm that you want to leave - data you have entered may not be saved." in Firefox whenever I try to close the tab

Is there a way for me to close the tab without having to restart Firefox?

I have AdBlock loaded. Maybe I can do something from the developer console.

share|improve this question
    
Can you use Task Manager to end the task under the Applications tab? –  H3br3wHamm3r81 Feb 11 at 0:25
    
Can't you just click "leave anyway"? –  Mark Henderson Feb 11 at 0:26
    
@MarkHenderson: It will pop up the message again immediately thereafter. –  Wuschelbeutel Kartoffelhuhn Feb 11 at 0:26
    
@H3br3wHamm3r81: I dont want to restart firefox –  Wuschelbeutel Kartoffelhuhn Feb 11 at 0:27
    
I would kill Firefox, then hope it asks me if I want to recover my session when I relaunch it. I know it gives you the option to only reopen certain tabs when you relaunch after a crash. –  Michael Frank Feb 11 at 1:33

3 Answers 3

up vote 2 down vote accepted

Since you didn't mention the site you're having problem with, try these yourself:

  1. Does it only happen with Firefox? not with other browsers ? (probably all browsers will show same behavior)

  2. When you get the prompt ( usually, when you are filling a form, or writing something to post), do you get two options : Leave Page and Stay On Page ? If you get, then click Leave Page

  3. If you don't get such options, then disabling JavaScript is a solution, but rather than doing it, open the site from a script blocking proxy, like www.ninjacloak.com

share|improve this answer
    
I won't publish the URL because I don't want others to click it. 1. It will probably cause other browsers to behave similarly. 2. I already mentioned that this is a scammer website and clicking 'Leave Page' will only trigger the same message. 3. Disabling Javascript will probably not remove the script that's currently causing the message in main memory to be stopped, or not? I don't want to visit the website any more, I just want to leave it. –  Wuschelbeutel Kartoffelhuhn Feb 11 at 0:48
1  
did try disabling JavaScript? AFAIK these alerts are powered by JavaScript. –  MAKZ Feb 11 at 7:47
    
Wow, I just did that in about:config and it worked; I didn't have to restart firefox. Afterwards, I just toggeled it back. Thank you –  Wuschelbeutel Kartoffelhuhn Feb 11 at 9:47
    
thats what i said in point #3 . open the site from a proxy that disables all JavaScript, like www.ninjacloak.com, which requires fewer clicks and less time than about:config –  MAKZ Feb 11 at 10:31
    
The site was already open in a regular tab. The issue was just getting away from it or closing it. If I go to this proxy site (in another tab), open the malicious website from the proxy, then the original tab is still open. –  Wuschelbeutel Kartoffelhuhn Feb 11 at 18:11

Nuke it from orbit, its the only way to be sure.

Actually... quite literally. I'd probably kill the browser process, restart the browser, clear the caches, delete it from history... etc. There's ways to make browser windows that are resilient to most other ways of closing a window.

share|improve this answer
    
Then block the site permenently. –  Psycogeek Feb 11 at 6:05

Place your cursor on top of (or over) the window.

Hold down the ALT key and press and release F4

If it keeps coming back after that maybe MalwareBytes and Another AV product.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.