Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When listening to some music on my remote computer, the audio quality is low. I've found this:

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32\Terminal Server\RDP

There are two interesting keys:

  • EnableMP3Codec - with 0x00001
  • MaxBandwidth - this is 0x000056b9

Does anybody know anything about these keys? How should they work? What if i set EMP3C to 0? What if i change MaxBandwidth to higher number? Should i change these on my local computer and/or on the remote computer?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Use VLC or some kind of streaming. RDP is simply not made for this purpose. (Any streaming audio solution can work.)

share|improve this answer

The registry key you found isn't an important one but be careful when you are editing the registry.

"MaxBandwidth - this is 0x000056b9"

MaxBandwidth is what controls the bandwidth, the hex value "0x000056b9" converts to 22201 which is the speed in kbps.

Doubleing this to 44402 should increase the quality greatly, and 44402 in hex is "0x0000ad72".

Go ahead and change it on both computers from:

0x000056b9

to:

0x0000ad72

You may need to restart your comptuer to notice any affect.

share|improve this answer
    
I've tried this but nothing really changed. Music sounds crap. If I seek in the song, the sound totally screws. I have to logoff/logon to repair it. –  Vili Nov 20 '09 at 14:22
    
Different music player? –  Shiki May 22 '10 at 15:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.