Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While running a restore function of a backup program I had to stop it. After that I noticed that most (all?) icons on my desktop and inside folders show small locks. The backup software company didn't help. They say it's a coincidence.

It's been several months already, but all the old folders and files still show locks. I checked the obvious file ownership settings. Everything looks normal. The account that I use has full rights and I'm able to manipulate the files, so the lock icons don't seem to indicate any restrictions, however they are still present.

Just to clarify, new files and folders don't have the locks.

share|improve this question
    
Try resetting the Access Control List (ACL) permissions. From a command prompt, type the following commands: 1. takeown /f "%userprofile%\Desktop" /r /d y >nul 2. icacls "%userprofile%\Desktop" /grant:r %username%:F /t /c /q –  and31415 Feb 11 at 20:48
    
I'm getting ERROR: The current logged on user does not have ownership privileges on the file (or folder) ".....". –  user1566515 Feb 11 at 21:40
    
Did you get that error after the first or the second command? Did you get just a single error or multiple ones? I guess the "....." is supposed to be the actual file/folder name? –  and31415 Feb 11 at 21:43
    
Sorry for so few details. 1) the error appears after the first command. I ran it in a sub-directory as a test. This single error refers to a folder. Administrators has full access to this folder and I think my account is a member of the Administrators group. –  user1566515 Feb 11 at 21:50
    
Type icacls "%userprofile%\Desktop" and post the output of the command. –  and31415 Feb 11 at 21:54

1 Answer 1

Found this as reference to run for likewise locks on folders and icons "missing user group" :

  1. Right-click the folder or drive that has a lock icon and select "Properties".
  2. Click on the "Security" tab, then select "Edit..." to change permissions. Click "Add.."
  3. In the text field for "Object Name", enter in "Users" (without quotations). Hit "OK".
  4. "Apply", "OK", and voila, the padlock next to the icons should be gone.

(via http://social.technet.microsoft.com/Forums/windows/en-US/e8347f6f-e835-42e1-8509-eee38f83bb05/how-do-i-get-a-lock-icon-on-my-folder-to-come-off?forum=w7itprosecurity)

share|improve this answer
    
Wouldn't this allow all users to access all files in that folder? –  user1566515 Feb 12 at 1:09
    
Wouldnt that depend on the rights you set for users for that folder? e.g. "only read" ? –  edelwater Feb 12 at 17:43
    
I think this would be a brute force approach. I know that I'm logged in as a member of the Administrators group with full control allowed. If Windows shows a lock on a folder, that implies that something else is wrong and needs fixing. –  user1566515 Feb 12 at 20:40
    
What is the difference in security settings (groups, rights) between a folder WITH a lock and a folder WITHOUT a lock icon? –  edelwater Feb 13 at 22:54
    
That depends. Some "locked" folders have same security settings as "unlocked" folders. That's what's strange about it. Also, I'm logged in as the owner of the folders with all possible permissions. Could it be a Windows bug? –  user1566515 Feb 14 at 0:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.