Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Ubuntu 12.04.desktop on VMware. I'm connecting to the Internet through a proxy.

I can browse with Firefox, but when I try to ping any domain, I get this message:

12 packets transmitted, 0 received, 100% packet loss, time 11089ms

I put my proxy in network settings, but that didn't solve the problem.

ifconfig:

eth0      Link encap:Ethernet  HWaddr 00:0c:29:8e:87:b5  
          inet addr:192.168.244.130  Bcast:192.168.244.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe8e:87b5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4001 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2706 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4826988 (4.8 MB)  TX bytes:247945 (247.9 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:548 errors:0 dropped:0 overruns:0 frame:0
          TX packets:548 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:46534 (46.5 KB)  TX bytes:46534 (46.5 KB)
share|improve this question

1 Answer 1

Maybe your firewall filters out icmp packets. Proxy is for http/ftp/https protocols, not for icmp.

share|improve this answer
    
how can i check this ? –  medo9971 Feb 11 at 21:37
    
Try to ping from your host os, or try to set VMWare networking to bridged mode (if ping is working from the host), or you can review vmware network setup (is this a vmware workstation or server, esx?) –  zilahu Feb 11 at 21:44
    
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data. –  medo9971 Feb 11 at 21:48
    
its work ok and i use vmware workstation –  medo9971 Feb 11 at 21:48
    
Pinging localhost: it is work because the packet doesn't leave the host this will work on ubuntu guest too :) if you use NAT networking in vmware, then the host os firewall can cause troubles. If you use Windows you can enable icmp on the Windows Firewall control panel. E. g: sysprobs.com/enable-ping-reply-windows-7 –  zilahu Feb 11 at 22:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.