Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Java stopped running unsigned applications one day.

Your security settings have blocked an untrusted application from running.

Java security useless error message

The documentation states that I can add a site to an exception list to get around this problem. However, I am trying to run a Java applet for WebSDR usage, and there are many sites with many applets needed. It's a real hassle to have to do this, especially when I'm using Chrome and it already prompts me before running Java at all.

Java has become almost completely useless to me, and I'd like to fix that by toning down the security a bit. Is it possible to either disable the blocking of unsigned apps, or add a wildcard of URLs to the exception list? I've tried adding * or http://, but the "Configure Java" panel won't except either of these.

share|improve this question
This can be controlled by the Java Control Panel Applet. You will require administrator rights to change the setting. – Ramhound Feb 12 '14 at 3:35
@Ramhound I have used that applet, and there is no setting on it I can find to allow unsigned apps. – Brad Feb 12 '14 at 13:39
besides the Java problem: the SDR receiver mentioned in your screenshot and many other using the same software now have a HTML5 mode that does not require Java! Tried with the latest Firefox and runs perfectly. I guess it also works in Chrome. – Ale Dec 17 '14 at 21:53
@Ale Yeah, I've used it. It's good stuff! Unfortunately, not all of the hosts use the HTML5 version. – Brad Dec 17 '14 at 21:55
@Brad and do you still the java unsigned applet problem or is it solved meanwhile? – Ale Dec 17 '14 at 22:02

Java 8u25

Warning: These settings expose security vulnerabilities known to Java. Not for the the average user.

I was having a lot of tools blocked by Java. I set the options below and then added to the site exception list. I was then able to run all of my older applets that were previously blocked after a browser restart.


**JNLP File/MIME Association - Always allow

**Secure Execution Environment - Uncheck Show sandbox warning banner, uncheck warn if site certificate does not match hostname, uncheck show site certificate from server even if it is valid

**Mixed code - Disable verification

**Perform certificate revocation checks on - Do not check

**Advanced Security Settings - Uncheck enable blacklist revocation check


**Add the site to Security tab > edit site list > add button > type URL or IP.

share|improve this answer
Where did you get this information seems strange you provide no context almost like your just copying and pasting fron some source, even if I overlook that problem, the formatting could be improved – Ramhound Dec 17 '14 at 21:47
Did this work for you though? – sunkenruin Dec 19 '14 at 16:42
This worked for me when nothing else did! Thanks, this solved a huge problem! – AresAvatar Jan 19 '15 at 23:21
Thank goodness for stackexchange, this was blocking me from doing my homework. +1. – ApproachingDarknessFish Oct 27 '15 at 1:57

[Doesn't work in Java 8+]

Go to the Java Control Panel. In the Security Tab put the security to Medium and if the applet is not signed but doesn't require full permissions it should run. If it needs full permissions. This will prompt you for continuing. See details here:

As for Chrome if you enter in chrome://plugins under Java plugin settings you can also set "always allow" not to see the prompt.

share|improve this answer
I tried "medium", but the app must be requesting full permissions as I still get prompted. – Brad Feb 12 '14 at 13:37
Right...The prompts are by design at that level of security – Ramhound Feb 12 '14 at 13:45
Medium was removed in Java 8. Any workaround? – Quantum7 Nov 4 '14 at 12:15
How damn annoying. Java disallows me to run software, eventhough I trust it. – Christophe De Troyer Nov 27 '14 at 21:23

If you continue to receive this error after adding the site to the exceptions list of the Java control panel, try editing [JRE install directory]\lib\security\java.policy

Inside the grant block, add

permission "", "connect,resolve";

Substitute your host/IP and port.

share|improve this answer
To edit it, are you just talking about a plain text file, or using a special program? – Canadian Luke Jan 13 '15 at 23:38

You must log in to answer this question.

protected by Community Sep 30 '15 at 19:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .