Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've set Firefox to always ask me whether to activate a plugin when a site uses them. Normally, I will see a grey box on the page where the plugin is used, in which I can click to activate it.

For some pages, however, Firefox displays a large bar at the top asking me whether to active the plugin, see the image below. I assume this is because the flash or applet is not actually visible on the page, but it used to just be a small, brief message in the address bar, instead of a big, intrusive bar I have to manually close down. And it's unnecessary too, since I can just click on the plugin icon next to the address (also seen in the image) if I wanted to activate these hidden plugins.

How do I stop this bar from appearing? I've searched all over Google, and under about:config too, but found no answer.

The bar in question

share|improve this question
    
Are you running Ubuntu? What Firefox version are you using? –  and31415 Feb 12 '14 at 14:28
    
@and31415 Yes, and 27 –  adcoon Feb 12 '14 at 14:33
    
Great question. I really wish Mozilla would stop ruining their UI. –  BoffinbraiN Nov 29 '14 at 17:30

3 Answers 3

up vote 9 down vote accepted

Solution

I was annoyed too by the notification since it was introduced. There's no user setting which can control it, and probably there never will be. Disabling click-to-play wasn't an option for me, so I looked for possible solutions.

The manual way

I'm listing this first as it's the most efficient way.

  1. Close Firefox.

  2. Add the following code to your userChrome.css file:

    notification[value="plugin-hidden"]
    {
        display: none !important;
    }
    

    It is located in the chrome subfolder inside your Firefox profile folder. Create one in case it doesn't exists already. Here's an example: userChrome-example.css.

    Note As reported by @Smylers, !important doesn't seem to be needed and could be omitted.

  3. Start Firefox again.

Userstyle

If you have the Stylish add-on installed, you can get the Notification bar for 'hidden plugin' - disable style:

This style hide notification bar (infobar) for hidden plugin activations - eg. hidden frame or non-visible div.

Using an add-on

Install the Hide Plugin Notifications add-on:

Hides the hidden-plugin information bar in Firefox.

It basically injects the custom CSS code every time you visit a website. No restart required.

References

share|improve this answer
1  
Beautiful, the manual way works like a charm. Thanks –  adcoon Feb 12 '14 at 16:02
    
I'd really like to give you zillions of +1. –  metadings Aug 5 '14 at 11:23
    
You're a life-saver. I can't believe how many sites use hidden Flash trackers. –  BoffinbraiN Nov 29 '14 at 17:29

This comes from the Firefox Click To Run feature whereby plugins can be set to require activation by the user each time they are encountered.

Recent versions of Firefox have marked some plugins Click To Run by default. This is due to a perceived security risk with the plugin. This includes certain versions of Flash and Java.

To change the settings, go to Tools -> Add-ons then select the Plugins tab. Each of your existing plugins will be listed, along with a drop-down menu from which you can select Always Activate if you so wish.

share|improve this answer
2  
The settings I use for plugins are intentional. I'd like to keep them deactivated by default but get rid of the message. It is unnecessary and intrusive –  adcoon Feb 12 '14 at 13:12
    
Answers like this are typically who these banners are aimed at... users who don't mind things pushed down their throat –  Precastic Dec 1 '14 at 8:18

There is also a Firefox addon:

Hide Plugin Notifications:

"Firefox will now show an information bar for every site that uses a hidden plugin, to aid discoverability for users. This addon will let you turn off that infobar, if you know about the icon in the location bar. This is especially helpful if you have Flash marked as click-to-play."

It works like a charme!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.