Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The primary problem is that the USB ports do not work on our Windows Home SP3 laptop (Acer).

Upon restarting, whatever devices try to install automatically with the wizard, I get a "Data is invalid" error when it tries to install.

Even a plug and play monitor comes up with the same 'Data is invalid' error via VGA.

I have tried to manually install the latest chipset package from the Acer website, it installs but I get the same 'Data is invalid' messages popping up during the install.

I have also tried removing the devices from the registry in the HKLM System ControlControlSet Enum PCI, USB and USBSTOR.

Confused and frustrated.

share|improve this question
up vote 3 down vote accepted

I found something hopeful here. I'm copying it here:

Why do I get a "data is invalid" error when installing a driver in WindowsXP or 2000?

This error appears to be due to a protection problem in the Windows registry and can occur with a variety of drivers (sound cards and SCSI drivers have been reported). To fix this problem, go to Start, Run... and type "regedt32" without the quotes to run the Registry Editor. Navigate to


and you will see a number of keys of the form "VEN_xxxx", where xxxx are strings like "1102&DEV_0004&SUBSYS_00011103&REV_04". Under each of these folders will be another folder with a long numerical name. Open each folder and look for the "DeviceDesc" which matches the hardware you are trying to install. Right Click on the "VEN_xxxx" for that device and select 'Permissions' and then tick "Allow" for "Full Control". Close Regedit and then continue with the installation of your device.

Now, since I have never had this problem, I cannot verify that this works, but hopefully it helps.

If it doesn't work you may have to try a reformat and reinstall.

share|improve this answer
See also:… (first hit on google) – brandstaetter Nov 17 '09 at 12:34
I applied Full Control permissions to the SYSTEM user throughout PCI, USB and USBSTOR and it all immediately started installing and working properly. Thanks. – Kez Nov 17 '09 at 15:09

My solution was using Windows Repair All in One (v2.5.1).

I got this same error message.

  1. Tried to do video driver update (Nvidia) and the got the data is invalid and could not continue.
  2. bought a new Radeon card. Went to install it and SAME data invalid error occurred.
  3. attempted Windows repair (Windows 8.1): it would NOT repair because "data is invalid".

I normally do not recommend programs but this one is free (I donated after it fixed my system). I am NOT associated with the author/program. If you are in the same boat. Try this before completely reloading your OS.

It's at and is called Windows Repair All in One.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.