Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using the newest VMWare player on a Windows 7 machine. When I have the player open on one of my two monitors I get some weird behavior.

For instance, if the player is open on monitor 2, and I minimize firefox on monitor 1, my mouse will instantly switch to the monitor 2 and be centered within the VMWare player window.

This happens when I minimize any window after having been working in my VM. I hope there is a setting or tweak that I am not aware of that can remedy this.

EDIT: Through more testing I have found that this only occurs when the VMWare player is full screen on either of my two monitors.

Also, I found people having the exact same issue at:

share|improve this question

Although this tip is for Vista, it may still work in 7:,1644.html

Be careful inside the registry and dont change anything besides what the website tells you to.

Its only a minor change, you may have to restart your comptuer to experiance the effect.

share|improve this answer
This did not work unfortunately. – Bryan Rowe Nov 18 '09 at 16:12
Ok when you get your mouse out of the VM, try minimizing the VM window. Then it should stop it from stealing the focus of other windows. – Tanner Collin Nov 18 '09 at 22:36
Sure, but what if I have Visual Studio full screen on my VM and then on my host I have a few windows open that I am using to help me work in Visual Studio IE: chrome, ms project, outlook, etc? – Bryan Rowe Nov 20 '09 at 20:13

The page @Tanner Collin originally suggested seems to be returning 404 errors now, but I did find it in the waybackmachine.

I also had a look for other pages detailing how to prevent windows stealing focus. There are a number out there, including these at and

Also, this forum thread is interesting, since it describes problems with applications resetting this setting.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.