Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I asked a question similar to this one about an hour ago but my account got messed up somehow and it wont let me comment anymore :p

Anyways, I have a 20 year old IDE Conner Hard Disk attached to a live disc parted magic os using a usb connector. When I try to mount the disk it says:

udevil: error 64: unable to determine device fstype

What should I do?

share|improve this question
    
You are correct that reformatting it will erase everything. If the data is that important, then you may want to consider taking the drive to a data recovery specialist company. –  Christopher N. Boisjoli Feb 15 at 4:07
    
Does anything show up in Disk Management? Do you know what version of Windows it was from? Try hooking it up to a Mac? –  miken32 Feb 15 at 4:13
    
windows disk management tells me to initialize the disk (but doing so would result in total data loss) –  Skii Squad Feb 15 at 4:15
    
Boot a live linux disk that can read old FAT tables (Fat16 perhaps?) and then copy it to another drive –  AthomSfere Feb 15 at 4:16
    
Okay, whats a good linux distro to use for this? (preferably something i can download in less than 10 mins) –  Skii Squad Feb 15 at 4:18

3 Answers 3

You can try directly accessing the drive at the block level under Linux and extract an image of the drive into a file (you must be logged in as root to do this):

dd if=<drive device file> of=<desired image file location> bs=512

You can then analyze the disk image using software tools. If that doesn't work, your only other choice is to send the drive in to a professional data recovery service.

share|improve this answer
    
Can i do this with Ultimate Boot CD? –  Skii Squad Feb 15 at 4:48
    
Yes, you can. dd is part of the GNU Core Utilities, so it's in virtually all Linux distros. Be sure to boot into Linux (use the Parted Magic option; Parted Magic is a Linux distribution designed specifically for partitioning drives) and mount your main hard drive so that you can write the image to it. In case you need help, have you worked with the Linux command line before? –  DragonLord Feb 15 at 4:50
    
i gotta burn a new ubcd and ill give it a go –  Skii Squad Feb 15 at 4:58
    
To determine which device file in /dev is the old hard drive (which you've stated is connected to USB), see this question: How do I figure out which /dev is a USB flash drive? –  DragonLord Feb 15 at 5:00
    
Okay i tired this command and it says: 0+0 records in 0+0 records out 0 bytes copied.... Anything else i can try? –  Skii Squad Feb 15 at 6:14

You might search the internet for some specialized software to be able to read and allow you access to the data on the drive. Just because windows is asking you to format it doesn't necessarily mean the data still isn't there.

Buy yeah, don't format It

share|improve this answer
    
ive tried about a half a dozen data recovery programs and they all do is one of 3 things: 1. Shows drive but says it has 0bytes and then refuses to check the drive 2.Checks the drive but stops immediately with no results. 3. the program crashes –  Skii Squad Feb 15 at 4:16

Sounds like the disk might be old enough that on the original machine you had to enter all its parameters by hand into a table in the BIOS (number of sectors, cylinders, platters, heads etc). If so, all the relevant information would be printed on the disk label, which is hopefully still readable.

This doesn't help much; I don't know how to translate that disk attachment strategy to modern software, but if you can find a contemporary PC (with BIOS that doesn't just assume it can auto-detect disks, but has the disk parameter table in its setup menu) that ought to be able to read the disk.

Or perhaps this answer may trigger a better one from someone who DOES remember how to access old disks via newer software.

share|improve this answer
    
i have all of that information for this specific drive, how would i input all that into my bios? –  Skii Squad Feb 15 at 18:11
    
You would need a BIOS old enough to have a "disk parameters" page in the BIOS setup menu. –  Brian Drummond Feb 15 at 20:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.