Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just noticed that when I updated to Windows 7, almost all my movies are unwatchable because the speech volume is too low.

All was fine with Windows XP SP3.

I have latest updates for Windows 7.

I have tried several solutions such as: control panel sound settings, vlc compressor. Yet, none seem to work.

They say its because of 5.1 and 2.1 audio system incompatibility or something. But no solutions worked so far.

I have:

  • Windows 7 32bit. Latest updates.
  • Sound card: SB Live! 24-bit. Driver version: 5.12.1.2020
  • Two speakers.

I haven't touched my computer physically at all. These 5.1 sounds just broke after Windows 7 install.

share|improve this question
    
Which outputs are you using on the card and into how many speakers? –  mtm Feb 25 at 18:14
    
Check the Tools menu > Effects and Filters > Audio Effects > Graphics Equalizer. You may need to uncheck "2 Pass" and "Enable". –  harrymc Feb 25 at 20:28
    
Is Windows 7 32-bit or 64-bit? Which audio driver version are you using? –  and31415 Feb 25 at 21:41
    
@and31415, Windows 7 32 bit. Latest updates. "SB Live! 25-bit" driver version: 5.12.1.2020 (driver date: 16.10.2009). –  Rookie Feb 27 at 18:09
    
@mindthemonkey, I have two speakers, i havent touched the card or wires physically at all when i installed Win7. –  Rookie Feb 27 at 18:10

2 Answers 2

There is always a workaround for generic low-volume sound problem that uses to work: AC3Filter. It has so much audio controls that, if you are patient enough, you will probably solve all your low-volume issues.
In your case you just need to increase Master and maybe DRC control on AC3 Configuration:

AC3Filter v2.6 - Increase Master (and DRC if needed)
Even more: I have often used it to solve that stupid 5.1 sound behavior of so many movies that makes explosions and noisy sounds too high... and voices in conversations sound too low.
I have found it valid for most media player (BSPlayer, Windows Media Player... etc), audio player (WinAmp, iTunes... etc) and even most audio playing (Java, Flash... etc). A real must-have utility.
Of course, this is not solving the main problem (driver, hardware or Windows configuration) at all... but it is easy, fast and works!

share|improve this answer
    
Do i need to make own configuration for each movie? Can i just install that thing and be done with it forever? –  Rookie Mar 2 at 13:34
    
I tried to change master/gain, and some other things, but it doesnt make it sound normal at all. Why do i even need separate program to make sounds working on Windows 7 anyway? Currently the only way for me to watch these movies is to re-encode them with handbrake to stereo 2.1 format. then the sounds are fixed. –  Rookie Mar 2 at 13:43
    
Indeed, changes are saved for every movie you will play in a future. –  Sopalajo de Arrierez Mar 2 at 15:41
1  
5.- If you are going to buy another sound card (we still can not know if this will solve the problem), you could maybe try some USB one. 6.- Try another video player, just to discard it: BSPlayer, Media Player Classic, or Windows Media Player. 7.- If you have some virtual machine (like Virtual Box), try playing the video through (inside) it. VMs use to have no issues with audio matters. –  Sopalajo de Arrierez Mar 3 at 10:53
1  
Speech is the key here. adjusting the AC3 filter really is a good answer. The Center channel of many of the movies holds all the dialog, thats just not natural. Adjusting the Center channel up, and outputting to stereo in the AC filter does solve it, if not re-map the whole thing. MCP can also remap too. If the Audio has reverb and other noxious effects , it can be caused by other filters in the sound cards features. Given adjusting about 15 things, sound can be put back to normal. There have been many versions of the AC3 settings, older codec settings (XP) were more simple. –  Psycogeek Mar 3 at 14:20
up vote 2 down vote accepted

Looks like I fixed this problem on my own, in accident; simply by going to Windows 7 sound settings. This will not require any additional programs to work!

Step 1: Right click speaker icon

enter image description here

Step 2: Click "configure" button on your speaker device

enter image description here

Step 3: Select stereo (or appropriate setting for you) and click next and then finish.

enter image description here

For some reason I had "7.1 Surround" selected by default! No wonder why it made my sounds broken in movies.

share|improve this answer
    
See, it was a surround-sound problem; the system was trying to send the sound to eight speakers instead of just two, so it was getting diffused—imagine sending the same level of signal meant for stereo speakers to all eight! –  Synetech Mar 12 at 3:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.