Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to start emacs with LANG environment variable set to en_US.UTF-8, and I don't want to affect other programs.

In terminal, it could be realized using LANG=en_US.UTF-8 emacs. Then I created a shortcut in the launcher with this command. But when I clicked on it, an error dialog prompted out saying that:

Failed to execute child.
Failed to execute child process "LANG=en_US.UTF-8" (No such file or directory).

Why is that? And how to create such a shortcut?

share|improve this question
    
Here is a link to my .emacs setup in a stackoverflow related thread: stackoverflow.com/a/20736147/2112489 –  lawlist Feb 16 at 17:38
    
Thanks lawlist, but it'S different. I want to set it before emacs' start. This is not an emacs specific question. Sorry that I shouldn't tag it as emacs. –  Ben Feb 16 at 23:35

1 Answer 1

Use the env program for the command in the launcher (setting the Exec key in the according .desktop file):

env LANG=en_US.UTF-8 emacs

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.