Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Centos 6.5 in a Virtual Box VM. Everything works smooth, except for SSH logins. It takes ages for the command prompt to display.

With some verbosity added:

debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /Users/verhage/.ssh/id_rsa (0x7f82a2600350),
debug2: key: /Users/verhage/.ssh/id_dsa (0x0),

Of course I googled and this seems to have to do with a hanging reverse DNS lookup right? I edited my /etc/ssh/ssh_config and it looks like this:

Host *
    UseDNS no
    GSSAPIAuthentication no
# If this option is set to yes then remote X11 clients will have full access
# to the original X11 display. As virtually no X11 client supports the untrusted
# mode correctly we set this to yes.
    ForwardX11Trusted yes
# Send locale-related environment variables
    SendEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
    SendEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
    SendEnv LC_IDENTIFICATION LC_ALL LANGUAGE
    SendEnv XMODIFIERS

As you can see, both UseDNS and GSSAPIAuthentication are set to no. As setting these parameters to no are the only suggestions I can find online, what could be my problem?

share|improve this question
    
Ok, this was very, very stupid. I have been editing the client configuration file... –  verhage Feb 17 '14 at 21:40

1 Answer 1

I had the same issue. Upon searching I got the solution here:

Add the following line to /etc/resolv.conf:

options single-request-reopen
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.