Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I formatted a usb external hard drive in linux with ext4 format.

In windows 7, I deleted all these partitions using disk management. Windows doesn't display the drive when I connect it.

How do I fix this?

share|improve this question
    
When you say "Windows doesn't display the drive", where do you mean? Do you mean in the device manager? Because if you mean under "My Computer", then that is normal. Disk drives never show under "My Computer". (Though Windows says "Hard Disk Drives", causing lots of pain and confusion, it actually lists only mounted partitions.) There is probably nothing to fix; everything is fine. It should not show. –  David Schwartz Feb 18 at 7:57
    
To complement what @DavidSchwartz said: Only actual partitions are visible in Windows Explorer. Since you deleted all partitions, nothing is shown. –  Daniel B Feb 18 at 7:58

4 Answers 4

Go to Control Panel. Choose Administrative Tools.

enter image description here

Choose Computer Management.

enter image description here

Navigate to Storage->Disk Management inside current window. enter image description here

Now we have few possibilities:

  • You may need to format the whole disk to achieve either FAT32 or NTFS filesystem to be recognised by system
  • You may need to assign a letter for the disk (sometimes system fails to assign one)
  • You may need to create a partition and set it to active

Other options would depend on how the Storage tab looks like for you. It would help if you provide us some more information from this tab when external HDD is connected.

share|improve this answer
    
Hi, I cannot see the drive in my computer. Also, in disc mgmt., Its shown as one green drive. My internal hard drive info can be seen clearly though (volumne, layout, type etc.) –  please click this Feb 18 at 16:27
    
Can you see this disk in diskpart? CTRL + R, then type cmd and in the command line type: diskpart - hit ENTER, list disk - hit ENTER. The list of disk will show. –  Battlefist Feb 18 at 16:41
    
Thanks. It says disk 0 and disk 1, both online. Both are of the same size so I am confused. Disk 0 has zero free space. How do I find which is the external and format it in windows format ? –  please click this Feb 20 at 2:10
    
oh ! how stupid of me. I just unplugged the usb disk and saw that disk 0 is online. So that is my internal HDD. But, is there a command to find out ? –  please click this Feb 20 at 2:12
    
How stupid of me to write Ctrl+R instead of Win+R. Glad you found It out yourself. Within few hours I'll update answer to meet your needs. :) –  Battlefist Feb 20 at 5:15

right click on my computer and open manage. now look for 'Storage'. I'm sure your hard disk will be visible there.

share|improve this answer

I'm taking a shot in the dark here, cause i don't really know how a format in linux is relevant vs a format in windows. But i'm going to just address how to install a hard disk after it is installed into a windows environment.

First make sure the drive is actually connected.

Right click on my computer > Properties > Device Manager

enter image description here

If the drive is found move on to the next step.

Control Panel > Administrative Tools > Computer Management > (Left Side) Storage > Disk Management.

At the bottom you will see all your physical drives. Go to the one that looks like:

enter image description here

Right click on that unallocated drive and Go to New simple volume:

enter image description here

goto Format this volume with the following settings: NTFS, Default, Name the volume, Make sure quick format is checked > Next.

Done. After this is complete, your drive should show up.

share|improve this answer

AFAIK in windows there's ( actually ) no way to use "native" ext4. You'll need external software ( like http://www.ext2fsd.com/ ) or whichever software you'll be able to find.

share|improve this answer
    
ext2 does not show me anything either. I had already tried that option. –  please click this Feb 18 at 16:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.