Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 3 USB flash discs

  • Transcend (worked on all computers except HP Desktop and OLD ASUS desktop)
  • Sony 8GB (worked on all computers except HP Desktop)
  • Kingston 8GB (worked on all computers except HP Desktop and OLD ASUS desktop)

and 3 computers:

  1. HP Compaq Desktop computer
  2. Old ASUS computer with 487 motherboard
  3. ACER notebook
  4. HP Notebook

I wasn't successful booting Backtrack 5 or Konboot on HP computer with none of my USB sticks, Acer and HP booted fine with all sticks. But older computer didn't boot with Kingston and Transcend there was error:

syslinux by blah blah No DEFAULT or UI configuration directive found Error boot>

I noticed, Kingston stick boot only with USB-FDD enabled but gives that error up, but Sony stick was successful only with USB-HDD.

Why works only some USB sticks on only SOME computers? I know every computer isn't same, BUT what is different in USB sticks?

All formated via FAT32 in Windows and created via Unetbootin (last version).

share|improve this question
    
You started going down the right way. It depends a LOT on the motherboard and BIOS that you are testing with. Not all USB drives are created the same, nor are motherboards. I don't have facts or science to prove my point, but that's more than likely what is happening. –  Kruug Feb 18 at 15:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.