Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 machine I'm trying to setup for development. Typically we access our development domains using a URL like user.site.dev. The DNS is setup for user.site.dev.sd.ourdomain.com. I am able to ping user.site.dev.sd.ourdomain.com but if I try to ping just user.site.dev it returns "Ping request could not find host user.site.dev."

When I run ipconfig it shows a connection-specific DNS suffix of sd.ourdomain.com, and when I edit the properties for the network adapter, the DNS setting under the advanced menu are checked as "Append primary and connection specific DNS suffixes" and "Append parent suffixes of the primary DNS suffix".

These are the same setting as I have on an XP machine, and they resolve the url correctly there; but Windows 7 doesn't seem to be appending the suffix correctly. Am I doing this wrong? Or has anyone else had this experience and found a workaround?

Update: I tried toggling the settings to "Append these DNS suffixes (in order):" and adding sd.ourdomain.com to the list, but the url still didn't resolve.

share|improve this question
    
We switched to a different naming convention, so I am unable to try peoples' answers below in order to verify they are correct. –  Soldarnal Jun 15 '11 at 2:13

7 Answers 7

This change worked for me:

  • Run gpedit.msc,
  • Browse Local Computer Policy,
  • Computer Configuration,
  • Administrative Templates,
  • Network,
  • DNS Client,
  • Enable Primary DNS Suffix Devolution Level - Set to 2
share|improve this answer

I was having this issue in windows 8; I found this link to have the correct fix.

In my case I only needed the registry change: set HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient\AppendToMultiLabelName to (dword) 1.

In my case I had to create the DNSClient entry; it was not already present.

share|improve this answer

Beware that manually configuring a search list will disable the devolution functionality. "The primary DNS suffix and any connection-specific DNS suffixes are not used, nor is the devolution of the primary suffix attempted." (according to the microsoft website: http://support.microsoft.com/kb/275553).

share|improve this answer

Don't forget ipconfig /flushdns and other ipconfig commands to flush cache entries.

OpenDNS has DNS bookmark aliases that might be worth looking into.

share|improve this answer

Bitmap and Charles below are correct, Microsoft has added a new feature in Windows 7 called DNS Devolution, and there is a policy setting to disable it, as follows:

Run gpedit.msc Browse Local Computer Policy -> Computer Configuration -> Administrative Templates -> Network -> DNS Client

Enable "Allow DNS Suffix Appending to Unqualified Multi-Label Name Queries"

That should do it.

share|improve this answer

DNS Devolution is a new concept MS has come up with to give finer controls over how far you search up the tree with an unqualified name. I think this is the root cause of the behavior you are seeing, which differs from the behavior of previous OS of simply stripping one level off the domain until you match or reach the end. http://technet.microsoft.com/en-us/library/ee683928%28WS.10%29.aspx

share|improve this answer

You need to also add .site.dev to your DNS search suffix list, and then order it as first. The ordering is not mandatory, but it will speed up searches if you're using these dev extensions often. If it is in your list already and still not working, make sure you're pointing to a DNS server that returns .site.dev results. If that still doesn't work, you can always specify the translations in your hosts file. See http://en.wikipedia.org/wiki/Hosts%5Ffile

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.