Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My situation:

  1. Need auto login for my Wheezy.

  2. Sometimes I'm away from my PC when it rebootsso I need to lock the screen after auto login.

When I type /usr/bin/gnome-screensaver-command -l it locks fine. But adding it to startup applications somehow does not work.

Any ideas how to solve my problem?

share|improve this question

Create executable script and add it to startup applications instead of screensaver initialization; this should work fine:

/usr/bin/gnome-screensaver &
sleep 1
/usr/bin/gnome-screensaver-command -l

When you add gnome-screensaver-command -l to startup, it runs when screensaver isn't fully initialized. Because of that it doesn't work.

share|improve this answer
    
I'm surprised this is not a built in option. Works well though. Any ideas about how insecure this might be? – pcnate Oct 22 '15 at 23:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .