Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have apache httpd server of version 1.3.27 running in the production server with OS version RHEL WS release 4 (32 bit).

We are using two instances of this httpd server. One for front end light weight which acts as a proxy to the other back end server. Both instances are running in the same RHEL WS 4 server.

Based on security audit, we are in need of upgrading the apache httpd. Changing the back end httpd to the latest version will involve more changes from development as well as testing. So we have planned to upgrade the proxy httpd alone to the latest version (say 2.2.25 or greater).

Please note that OS upgrade is not an option as of now.

As I couldn't find the latest httpd version in RHEL repo, I decided to compile from source by following this link. After installing some devel dependency package, I am still getting this error,

[root@localhost httpd]# rpmbuild -tb httpd-2.2.24.tar.gz
error: Failed build dependencies:
    pcre-devel >= 5.0 is needed by httpd-2.2.24-1.i386
    /usr/bin/apr-1-config is needed by httpd-2.2.24-1.i386
    /usr/bin/apu-1-config is needed by httpd-2.2.24-1.i386

I do have pcre-devel package installed with this version 4.5-4.el4_6.6. But it seems httpd-2.2.X needs higher version of pcre-devel.

I think the only way to resolve this is to again compile pcre-devel from its source. If that is the case, which version of pcre-devel should I use for my case with RHEL WS 4 ?

Also is there any other package needs to be installed to get rid off the config files ( apr-1-config and apu-1-config) errors ?

share|improve this question

migrated from stackoverflow.com Feb 19 at 14:03

This question came from our site for professional and enthusiast programmers.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.