Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My todler is continuosly pushing the cd/dvd button and trying to destroy the tray. I know it should be possible to let her life harder, disabling the eject button. How to do that? This is ubuntu (shouldn't matter) linux. See also the this related question.

And the same one as this one, but on windows

EDIT: this is Hardy

share|improve this question
1  
This reminds me of a video of someone who had a script that continuously ejected and closed the disc drive. There was a string connecting the disk tray to a baby's rocker. And the cd drive just rocked the baby! –  Jonno_FTW Nov 18 '09 at 16:14
    
@Jonno_FTW: A similar story comes from the German ubuntuusers-site. Someone created a 'benchmark' to measure how often the drive could open and close in a minute. Needless to say, somebody figured out how to do that via network and had some fun at work. –  Bobby Jan 4 '11 at 9:43

5 Answers 5

up vote 5 down vote accepted

You might want to try this out...

http://www.poweradded.net/2009/09/cddvd-tray-lockunlock-under-linux.html

share|improve this answer
    
This is good, it works pretty well (the code is not robust, but I can improve it myself, if I'll never need) –  Davide Dec 4 '09 at 4:54
    
This isn't working in Fedora 19. Using a Thinkpad T410 laptop. –  slm Dec 12 '13 at 2:06
    
Didn't work at first in Ubuntu but I didn't see the update to the post (search for "UPDATE1 03.Jan.2013" which had a fix that made the solution linked to, work again so don't miss that comment when giving it a shot. –  Björn Sep 13 at 18:03

At the command line:

eject -i 1

To return to normal:

eject -i 0

Or you can software eject it using:

eject

In all cases, you can add a device name if you have more than one ejectable device.

Apparently, this doesn't work with all versions of eject. If it doesn't with yours, you can bypass eject completely and do it the "hard" way:

echo 1 | sudo tee /proc/sys/dev/cdrom/lock
share|improve this answer
    
Thanks, but it doesn't work for my OS: $ eject -i 1 eject: invalid option -- i $ eject --version eject version 2.1.5 by Jeff Tranter (tranter@pobox.com) –  Davide Nov 18 '09 at 3:08
    
Grrr, comments don't align code snippet correctly, and cannot be edited! Let me try again: $ eject -i 1 results in eject: invalid option -- i - and you should be able to figure out the version from the other comment –  Davide Nov 18 '09 at 3:10
    
Weird. $ eject -i 1 works fine for me in Karmic. Version 2.1.5. –  regan Nov 18 '09 at 3:27
1  
If you want to do it the hard way, then <code><pre>sudo echo 1 &gt; /proc/sys/dev/cdrom/lock</pre></code> will work with any version of eject, because you're not using eject. –  gorilla Nov 18 '09 at 14:08
    
@gorilla, you should add that as your own answer.. –  quack quixote Nov 18 '09 at 15:28

Ubuntu's default automounter doesn't lock the CD/DVD try when it mounts an inserted disc. But if you mount the disc manually (say, with sudo), the tray should lock and stay locked until you dismount the disc.

So this process would accomplish what you want, without disabling other functionality, and you could even script it for quick access:

  1. Insert a disc,
  2. Run sudo umount /media/cdrom, then
  3. Run sudo mount /dev/cdrom /media/cdrom

Obviously, replace those paths and devices with ones your system uses.

share|improve this answer
    
Works, but it's inconvenient (actually I did know about that). Thanks for the answer, anyway. –  Davide Dec 4 '09 at 4:53

You might want to try out cdctl. It's available here: http://cdctl.sourceforge.net/. This switch will accomplish what you want.

       -oS, --lockdoor=S
          Locks the eject button so the disc cannot be manually ejected.  Requires  kernel  ver‐
          sion 2.2.4 or newer.  Set S to 0 to unlock the drive, and to 1 to lock it.

I've used this for the last 10 years on Fedora, RHEL, CentOS but the package is available as a tarball and should be compilable on Ubuntu. NOTE: The package hasn't been updated in a while but it works fine. There's a patch available on gentoo's site that fixes a small issue so that it can be compiled with more recent kernels. The patch is available here:

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-misc/cdctl/files/cdctl-0.15-cdc_ioctls.patch?revision=1.1

Once you've installed it you can use the command to lock the cd tray:

cdctl -o1

To unlock the tray:

cdctl -o0

I've recently repackaged cdctl for use on Debian/Ubuntu 12.10. It's available here, http://www.lamolabs.org/blog/wp-content/uploads/2011/01/cdctl_0.15-1.lamolabs.1_amd64.deb

share|improve this answer
    
Doesn't build on the most recent version of Ubuntu for me. Needs this patch from gentoo: sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-misc/cdctl/…. Seriously, why bother with a tool that won't take such a simple patch such as this. –  dgrant Mar 28 '12 at 4:34
    
Uhh, because it's the only tool I've found that does what I need. Besides the applying of the patch isn't that big a deal, I maintain a built version of this in my yum repository here: lamolabs.org/yum-repos/Fedora/14/x86_64/…. You can't use my rpm directly but you could convert it using the app alien, addictivetips.com/ubuntu-linux-tips/…. –  slm Mar 28 '12 at 4:46

A user left a comment on another question. The comment should have been a separate answer. I'm writing his suggestion here, since it might work for somebody (it doesn't in Hardy Haron) and might be more convenient than installing the code from my accepted question.

To lock:

sudo echo 1 > /proc/sys/dev/cdrom/lock

To unlock:

sudo echo 0 > /proc/sys/dev/cdrom/lock

Of course small shell scripts, possibly linked from the panel would be used.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.