Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Chrome gives this error, yet I can ping the server!

The server at can't be found, because the DNS lookup failed. DNS is the network service that translates a website's name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network. Check your Internet connection. Check any cables and reboot any routers, modems, or other network devices you may be using. Check your DNS settings. Contact your network administrator if you're not sure what this means. Try disabling network prediction. Go to the Chrome menu > Settings > Show advanced settings... and deselect "Predict network actions to improve page load performance." If this does not resolve the issue, we recommend selecting this option again for improved performance. Allow Chrome to access the network in your firewall or antivirus settings. If it is already listed as a program allowed to access the network, try removing it from the list and adding it again. If you use a proxy server... Check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server: Go to the Chrome menu > Settings > Show advanced settings... > Change proxy settings... > LAN Settings and deselect "Use a proxy server for your LAN". Error code: ERR_NAME_NOT_RESOLVED

$ ping

Pinging [] with 32 bytes of data:
Reply from bytes=32 time=103ms TTL=47
Reply from bytes=32 time=103ms TTL=47
Reply from bytes=32 time=103ms TTL=47
Reply from bytes=32 time=103ms TTL=47

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 103ms, Maximum = 103ms, Average = 103ms

$ ping

Pinging [] with 32 bytes of data:
Reply from bytes=32 time=665ms TTL=52
Reply from bytes=32 time=389ms TTL=52
Reply from bytes=32 time=541ms TTL=52
Reply from bytes=32 time=578ms TTL=52

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 389ms, Maximum = 665ms, Average = 543ms

I restarted Chrome, and I also disabled my network adapter and re-enabled it. I also ran ipconfig /flushdns. 'Predict network actions to improve page load performance' is already off.

share|improve this question
Did you solve it, and if yes, how? I'm seeing the same problem, I suspect the DNS is not propagating properly. – Mahn Dec 30 '14 at 16:14
I've seen the same problem, and this is not an issue with the data in the DNS system. I tried two different servers with dig, host and ping, all of which gave correct information, yet Chromium on my Ubuntu box couldn't find the record. (Chrome on Windows and on an Android tablet worked fine at the same time.) Clearing Chrome's DNS cache did not help. The problem went away after a couple of hours. – Curt Sampson Aug 13 '15 at 4:03
up vote 9 down vote accepted

You can try to disable Google Chrome's DNS Prefetching: Settings > Show Advanced Settings > Privacy and disable the option Predict network actions to improve page load performance.

Alternatively, flush Chrome's DNS cache.

enter image description here

More details here.

share|improve this answer
I already had Predict Network Actions turned off, but I think chrome://net-internals/#dns is the ticket! – Chloe Apr 4 '14 at 19:18
I have the same problem, but this solution for me it is not working. (I am using a new tld category) do u have any tips? – Nk SP Dec 26 '14 at 21:54
me neither. Everytime this problem occurs, Reinstalling the chrome is inevitable solution for me. – verystrongjoe Mar 12 '15 at 8:42
Does not solve: "DNS_PROBE_FINISHED_NXDOMAIN" – YumYumYum Jul 7 '15 at 4:20

I had the same issue. I'm working on a windows system (8.1) and had the problem with almost every page in google chrome, IE 11 and Firefox.

this is what worked for me

Win + R, type in "cmd", right click and select "run as administrator"

Then type the following commands (enter in this order):

ipconfig /flushdns
ipconfig /renew
ipconfig /registerdns

I did not have to restart my pc, but everything worked again all pages in the internet were available again.

share|improve this answer
In case anyone has a Mac: see this page for how to flush the DNS cache. – jvriesem Jul 30 '15 at 17:26
Strange thing is that a site was working on IE11, but not on Chrome 50, yet "ipconfig /registerdns" fixed the issue. – Jussi Palo Apr 26 at 8:19

It could be a DNS issue that can be solved by changing the DNS address to either Open DNS or Google DNS. May also require power cycling your PC and router. Check details here - One of my friend had this issue and later found out that his ISP put him through a safe browsing filter and everything worked fine after he asked the ISP to remove the filter from his IP.

share|improve this answer
I don't find your answer consistent with the fact that the OP can ping the server. IMO it's got to be browser-specific. – Dmitry Grigoryev Jun 16 '15 at 13:55
The thing is you can't be sure about the solutions for these kind of problem. They can be caused by browser, DNS, ISP and many other things. You just gotta keep trying one after another until it fixes. – Mahmud Jun 16 '15 at 22:37

i have had this issue REGULARLY and the ONLY fix for me is to set my Network Adaptor DNS to and (google) all web pages are now showing up!

share|improve this answer

You must log in to answer this question.

protected by Community Oct 19 '15 at 11:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .