Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running VirtualBox (4.3.6) on Mac OS X (10.9.1). I just upgraded my virtual machine from Windows 8 to 8.1 (Enterprise).

I installed Google Chrome in the virtual machine, but when I launch it, it looks like this:

Google Chrome looks funny

Opera also has this problem, so I suspect it has something to do with the Webkit engine.

Opera looks funny, too

I have uninstalled and reinstalled Chrome and deleted any Chrome settings from my AppData folder. I have never seen this before. What is causing it and how can I fix it?

share|improve this question
    
Have you tried any other browser based on Webkit, for ex. current version of Opera? My guess it's related to emulation of Windows environment and browser engine (thought it's indeed weird). –  Battlefist Feb 21 at 10:54
    
@Battlefist Good idea. Turns out Opera is also affected. –  William Jackson Feb 21 at 16:09

1 Answer 1

up vote 2 down vote accepted

This is caused by the Webkit engine trying to use GPU hardware acceleration in the virtual machine. There is an open VirtualBox bug that describes a similar problem.

You can resolve this problem by either disabling 3D Acceleration for the virtual machine or asking Google Chrome not to use it.

Option 1: Disabling 3D Acceleration

Open the settings for your virtual machine. In the Display section, on the Video tab, uncheck Enable 3D Acceleration.

Disable 3D Acceleration

Option 2: Running Chrome without hardware acceleration

Find the shortcut that you use to launch Chrome. Right-click the shortcut and select Properties. On the Shortcut tab, in the Target: section, add --disable-gpu to the end. The full text for the Target should be something like:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --disable-gpu

Chrome shortcut properties

When you launch Chrome with this shortcut, hardware acceleration will be turned off and the window will render correctly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.