Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to create a bootable usb drive from Windows 8 in order to install Debian on my laptop. I've looked up a lot of guides online, and they basically boil down to two categories:

  1. Write the iso file directly to the drive using some program equivalent to dd for windows like this guide.
  2. Use UNetbootin

I have tried using UNetbootin, and it simply doesn't work for me. The drive is not recognized at startup as bootable.

When I write the iso directly to the usb drive (using dd for windows or win32 disk manager), I get a strange sort of error. Instead of the disk image ending up on the flash drive, I end up with tiny filesystem (440 kb), with only a single file, "efi/boot/bootx64.efi". The rest of the several hundred megabyte filesystem from the iso is missing. I originally thought this might just be a compatibility issue with windows reading the filesystem, but when I try to boot from the USB stick, I'm dropped into a minimalist grub prompt, where it errors out because it can't find any of the files. From the grub prompt I can check that it too only sees the file "efi/boot/bootx64.efi". I've created bootable usb drives many times before, and I've never encountered something like this. I've also tried with three related debian images (debian-live, debian-netboot-testing, and debian-netboot-7.4.0), and they all behave the same way.

Is this some issue with the isohybrid filesystem on the debian iso? Is this an issue with usb drive writing programs on windows 8? Any help is welcome, I'm just looking to boot a debian installer.

share|improve this question
    
Did you try Rufus already? –  and31415 Feb 21 at 9:58

1 Answer 1

up vote 1 down vote accepted

unetbootin is a little sensitive about partition tables. It wants to see the entire stick as a single FAT MBR. Basically, you need to hose the MBR first:

I usually do this from the command line:

  1. Open a cmd window
  2. diskpart
  3. list disk (note number of your flash drive and double-check)
  4. "select disk X (replace X with number from step 3)
  5. "list part"

... delete part X until they're gone, then create part

That's pretty tedious.

This page seems to have better ideas:

https://wiki.archlinux.org/index.php/USB_Flash_Installation_Media#Using_manual_formatting

Your USB stick should work fine after that, provided of course it's large enough to hold the debian dist.

share|improve this answer
    
Thank you! The program Rufus linked from the archlinux page worked for me, but I also realized that there was another issue going on where it would not recognize my flash drive if I left it plugged in through a reboot. I'm not sure if my other attempts would have worked if I removed and re-inserted the flash drive when booting. In any case, I was able to successfully install Debian. –  Jeremy Salwen Feb 26 at 21:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.