Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When you open a picture file in Windows Photo Viewer the default background color is white. This is just fine in most use cases. But you might find yourself in a situation where your picture is very bright and you might want to view it on a black or a grey toned background.

a

Or as in my situation I have a historic map that's been digitized at really high resolution. There is a white border surrounding the map sheet, and I need to remove that before I can import that file and start working with the map in a GIS system. The only problem is I can't see white on white. I don't know which files need editing and which ones do not.

So is there a way to change the background color in Windows Photo viewer?

share|improve this question
1  
If you see this color as white, you might want to check your color settings. ;) It's #eef3fa. –  Daniel B Feb 21 at 12:29
    
Haha, ok! Well it's a sort of "white". :) –  sammyg Feb 21 at 12:34
    

2 Answers 2

As it turns out, Microsoft has not for-seen the need for an option that would allow you to do this with two clicks. But thankfully there are kind and knowledgeable people who go one step further than Microsoft and share their solutions to common problems like these.

So the way you can change the background color is by editing your Windows registry.

  1. Press Win+R key to open the Run prompt.
  2. Type in regedit and press Enter. Click Yes if prompted by UAC.
  3. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows Photo Viewer\Viewer
  4. From Edit menu, select New and then DWORD (32-bit). Name it BackgroundColor.
  5. From Edit menu, select Modify.
  6. Type in "ff" followed by the hexadecimal value for the color you want (e.g. ff000000 for black).
  7. Click OK and close the Registry Editor. Done!

When you open a picture in Windows Photo Viewer now you should see a black background color.

b

The white border is now better exposed and I can see what files need editing. A black background also makes your regular pictures (not many people are looking at maps in Windows Photo Viewer) pop out. It gives you better view of the picture and makes it easier for you to decide which ones to keep and which ones not to keep, in case you are culling photos inside Windows Photo Viewer. Some users might find that a grey background is a better choice, it's kind of the mid option between white and black.

Here's an example with a shade of green.

c

All the credit goes to HTG. I just wanted to share this with you guys and give you an idea how this can be helpful. This has been tested and is working in Windows 8.0. Because Windows Photo Viewer has been included with Windows XP and Windows 7 it should work with those OS-es. In Windows Vista it was replaced by Windows Photo Gallery, so those users might need to find the proper registry key and then add the same DWORD value.

share|improve this answer
1  
FYI, this feature has been available since Windows Vista: the photo viewer was called Windows Photo Gallery, and was later renamed in Windows 7. This setting have since remained unchanged till Windows 8.1. In Windows Vista the registry key is HKEY_CURRENT_USER\Software\Microsoft\Windows Photo Gallery. The actual value follows the ARGB format, but only fully opaque colors are taken into consideration (i.e. ffxxxxxx). –  and31415 Feb 21 at 15:17
    
Thanks for the info! I can confirm that the key you posted is essentially correct. I still have one machine running Vista Ultimate 64-bit at home, so I took a peek inside the registry. Just remember to create the DWORD inside the sub-key Viewer. So that would be HKEY_CURRENT_USER\Software\Microsoft\Windows Photo Gallery\Viewer instead. –  sammyg Feb 21 at 21:53
    
Yes, the Viewer subkey is the same indeed. BTW, I can confirm it works in Windows 7 too. As for Windows XP, you could use a third-party viewer to workaround the limitation. Feel free to update the answer with the additional info I provided. –  and31415 Feb 21 at 22:41

Another solution:

It seems it is a common - problem. To fix this problem, you have to remove the incorrect color profile. To do this, follow these steps:

  • Click Start, type Color Management in the Start Search box, and then press ENTER. In the Color Management dialog box, click to select the Use my settings for this device check box.
  • In the Profiles associated with this device list, click the color profile that you want to remove, and then click Remove.
  • Note If you receive a warning message, click Yes. Close the Color Management dialog box and then restart the computer to apply the
    setting.

  • If there is no color profile present, then Click Add, and add sRGB IEC61966-2.1 color profile and make it default. Then restart.

Source: http://superuser.com/a/383689/9594

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.