Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In my .emacs, I am using this theme:

(add-to-list 'custom-theme-load-path "~/bin/emacs-theme")
(load-theme 'monokai t)

It works when I open emacs in a standalone window: emacs afile.c.

But when I open emacs like 'emacs -nw', the background is green. How can I fix the background to be the same color?

share|improve this question
up vote 0 down vote accepted

Text terminals usually do not support more than 8 background colours. You can wrap your settings into

(if window-system ...)
share|improve this answer
    
Please this in where? .emacs? – michael Feb 22 '14 at 5:49
    
@michael: Yes. You can specify the colours for the text based mode in the else part of the if. – choroba Feb 22 '14 at 8:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.