Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have apt-get process running on my server and I cannot kill it.

root     26386 99.7  0.0  25588  2844 ?        RN   06:52 956:49 apt-get -qq -y update

I used kill 26386 first, then tried kill -9 26386 (as root), nothing happened.

I also killed parent process (PPID is now 1, i think init collected it). The process is still running and the worst thing - it consumes lot of cpu time. The only think I can do with it is lower its priority.

I cannot understand, why kill -9 isn't working. I just thought, it's only signal for kernel to clean the process and the process can't do anything with it. Am I wrong? I'm using Ubuntu server 12.04 LTS with kernel 3.5.0-34. It's currenty not possible to reboot the whole machine to resolve this problem...

Any ideas how to kill this process? Or is this bug in kernel?

Thanks for any ideas.

share|improve this question
1  
kill -9 might not immediately clean up a process, if it is inside a syscall. So the combination of high CPU usage and non-working kill -9 seems quite bad. Try kill -SEGV, as this might propagate into the syscall. –  Eugen Rieck Feb 22 at 22:08
    
are you root? if not you need sudo kill -9 26386. –  assylias Feb 22 at 23:10
    
I'm root, I think if I were not, I would probably get Permission denied as result of kill and I don't, kill does not output anything. I just tried kill -SEGV, it doesn't work either. I thought if the code would be inside of syscall, it should not cause so high cpu usage (probably would block, can't imagine the code will remain inside of syscall forever). When I look to /proc/26386/stack, there is only 0xffffffffffffffff. I noticed that some other proceses have some syscalls here, so if I understand this right, it means that code is not inside of syscall. But thanks for first ideas. –  Martin Feb 23 at 0:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.