Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using VMPlayer. My host OS is Windows 8 and my guest OS is Lubuntu. When I go to

Manage -> Virtual Machine Settings

and click on the 'Options' tab and click on 'Shared Folders' it says it is enabled and it says that it is linking to

C:\Users\userName\Documents\virtualMachineSharedDrive

but when I put a file in the

virtualMachineSharedDrive

folder, it does not appear in

/mnt/hgfs

and when I try to palce a file in

/mnt/hgfs

it says

fileName: Error creating directory: Permission denied

why is it denying permissions? And why can't I see files which are already in the folder placed by my host OS?

share|improve this question

I recently upgraded from Ubuntu 10.04 to 14.04. In 10.04 shared folders worked seamlessly with older versions of VMWare. But when I upgraded, VMware could "see" the shared folders (run vmware-hgfsclient) but they were not mountable at /mnt/hgfs/

I upgraded VMware to v6.0.4, reconfigured the VMWare tools (which rebuilds the modules against the latest kernel), and it worked flawlessly.

So, for Ubuntu 10.04 you need VMWare 6.0.4

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .