Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded my Ubuntu 8.10 to 9.04, and it not only broke the ATI proprietary fglrx driver, but also the ability to use the VESA or open-source ati or radeon drivers.

I have an ATI RV610 which is an ATI Radeon HD 2400 XT.

I have Linux Kernel 2.6.27-14-generic and 2.6.28-13-generic.

With fglrx, vesa, ati and radeon, the Xserver hangs the machine as soon as it starts by invoking X or startx, which is seen by observing that caps lock doesn't work. There's nothing useful in /var/log/Xorg.0.log, no errors at all. This is with either kernel.

When I download a new proprietary driver from ATI, I install it successfully on kernel 2.6.27, and it doesn't hang when X starts up, but it just shows a blank screen and does nothing. I also can't CTRL+ALT+Backspace out of X at this point.

In all the years I've used ATI's Linux drivers, this has happened almost every time I've upgraded my kernel, but it's been fixable with much effort. This time I'm really stuck.

Does anyone know how to fix these problems?

share|improve this question
This sounds more serious, but just so you understand it's normal to have to rebuild extra modules like this when you upgrade your kernel. I haven't used ATI in a long time (and even then, only on Debian), but as I recall before installing a new driver you had to completely purge the old one. Did you do that? –  Telemachus Jul 17 '09 at 15:41
I do know that it's normal to have to rebuild your kernel modules each time. In this case I didn't completely purge the previous driver. However, it's really odd that VESA and ati/radeon hang the system when X starts. I'm definitely never using ATI again, it's been too many years of this bullshit. –  Neil Jul 17 '09 at 16:28
Could you show your x configuration file? –  txwikinger Jul 17 '09 at 19:41
Hey! One friend of mine is having the same issue –  victor hugo Jul 18 '09 at 7:37
Have you tried EnvyNG? –  Stefan Thyberg Jul 19 '09 at 16:10

1 Answer 1

up vote 1 down vote accepted

The built-in support for ATI cards in ubuntu 9.04 is better. You shouldn't need the fglrx.

I would suggest doing some kind of test clean-install, though perhaps the Live CD would be sufficient to verify that ubuntu default ATI drivers will work for your system.

The reason I suggest clean install is that customizations for Video (e.g., directly using fglrx rather than using "hardware drivers" menu) and customizations for network (e.g., using ndiswrapper) mess with the upgrade process.

After banging my head against strange video problems (and network problems) after an upgrade, I solved my problems with a back-up of my data, including .mozilla directory, a list of installed packages, a clean install, and a manual restoration of my desired environment.

share|improve this answer
I clean-installed 8.10 and that worked, of course. Actually the 8.10 live cd hangs the system when you boot it without safe graphics mode. Given that after upgrading to 9.04 made the system hang when X was started with ati, radeon or fglrx drivers, I'm guessing the live cd does the same. But I haven't bothered to download a 9.04 cd image yet. I'm just getting an Nvidia card and never worry about this stuff again. –  Neil Jul 21 '09 at 17:08
Ubuntu 9.04 uses a newer version of X. ATI upgraded fglrx to work with the new X, but they dropped support for older graphics cards. Thus, if you had 8.10 working with fglrx and an older ATI card, upgrading to 9.04 will require that the built-in, non-proprietary drivers be used. –  pcapademic Jul 21 '09 at 19:24
@Neil: You used a binary-only driver and upgraded your kernel with it...and you think Nvidia will be better? You're in for a bit of a surprise, then... I don't know what happened to lose your ability to use the Free drivers, but a clean install will fix that. The new Free Drivers in 9.10 and 9.04 work quite well. –  Broam Dec 3 '09 at 14:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.