Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using CUPS to print to a USB inkjet printer (HP Deskjet 1010) from command line, like so:

lpr filename.txt

I'm looking to have the printer stop feeding paper through after it prints the text itself, rather than continuing to feed blank paper through.

I tried setting a custom page size, like so:

lpr -o media=Custom.4x4in filename.txt

However, the full remainder of the paper (A4 size) comes feeding out of the printer after the text, rather than the feed motors stopping after a 4 inch print. I've also tried longer physical paper sizes, printing on a default paper setting of A4 size, and the longer paper feeds out as well.

Is it possible to modify the driver or a setting within CUPS to disable the paper auto-feed after printing the given data?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.