Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have to learn working on Silver light application of VS2010. I have never used VS Studio before. When i try to install VS 2010 from this link http://www.microsoft.com/en-us/download/details.aspx?id=23691 . It gives an error that "Setup has detected that this computer doen't meet the requirement to install this software The following blocking issues must be resolved before you can install microsoft VS2010 service pack1 soft. package"and inside the menu I have

"Installation Requirements:

A compatible version of Visual Studio 2010 was not detected on the system. This update is designed for only the Microsoft Visual Studio 2010."

I have installed nothing prior to this VS 2010 installation unsuccessful try. Could any one please answer following questions ?

  1. What should i install prior to this vs 2010 installation ?

  2. Currently i have checked in "Uninstall a program of Window 7" I have nothing installed like SDKs etc.I even don't what is it used for ?Why do we need it ?

  3. Actually if VS 2010 is installed successfully then i have to work on silver light using c# and xaml. Could anyone please suggest me appropriate version installation according to my work ? Thanks in advance foe all this help.

share|improve this question
    
Visual Studio is in version 2013. Have you tried that yet? Try it from this link visualstudio.com/downloads/download-visual-studio-vs –  StBlade Feb 24 at 14:17
    
@StBlade I have first installed VS 2010 Express (c#) from this link visualstudio.com/en-us/downloads#d-2010-express then installed service pack 1 from this link microsoft.com/en-us/download/details.aspx?id=23691 (everything installed properly yet) But when i try to install Silverlight Tools from this link microsoft.com/en-us/download/details.aspx?id=28358 then it gives error that: –  user234839 Feb 24 at 14:22
    
"Setup has detected that this computer doesn't meet the requirement to install this software The following blocking issues must be resolved before you can install Microsoft silverlight 5 Tools for Visual studio 2010 SP1 software update" and below it gives : "Installation Requirements: The Visual Web Developer feature for Visual Studio 2010 SP1 must be installed before installation can continue. " –  user234839 Feb 24 at 14:23
    
Have you installed the the Visual Web Developer also? Silverlight may depend on the Web Developer part being there. –  StBlade Feb 24 at 14:29
    
No i am doing that nowm But do i need to uninstall c# edition before that ? –  user234839 Feb 24 at 14:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.