Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In IE 11 and before downloading files there's the annoying bar (as seen here under Internet Explorer 9 & 10).

I've been trying to disable it for a while... I tried enabling in gpedit.msc Turn off the Security Settings Check feature and tried adding a binary value exefile in the registry at: HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046} but that doesn't work.

I don't want to use an add-on since I need to simulate a user and just skip that bar. Does anyone have an idea how to do this?

BTW: The binary value exefile is because I checked in the cmd for assoc .exe which gave .exe=exefile.

EDIT: Another thing important to notice is that in IE11 there's no 'Do not save encrypted pages to disk' in: Internet Explorer > Tools > Internet Options > Advanced > Security like in this thread.

share|improve this question
1  
Do you mean your users don't have this box appear? Not only does this box provide you options when downloading a file it provides a level of security, in that a site can't run a script to download hidden files when you click an innocent looking button. – Matthew Williams Feb 24 '14 at 14:55
    
No, What I mean is that I'm simulating a user so I need to skip that bar. (I know the files that will be downloaded in advance) – Moshisho Feb 24 '14 at 15:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.