Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on a Mac. I'm trying to connect to a remote Ubuntu server.

I can successfully connect to it using ssh and scp commands in the shell. For example:

$ scp -i ~/Projects/keys/foo.pem foo_config.ini
foo_config.ini                                                                                                                                                      100%   15KB  14.7KB/s   00:00

However, I get errors when I try to connect on SFTP using the same public key in either FileZilla or CyberDuck.

I get an SSH_FXP_INIT error in CyberDuck: SSH_FXP_INIT error

I get exitcode 127 in FileZilla:

Status: Connecting to
Response:   fzSftp started
Command:    keyfile "/bar/foo.ppk"
Command:    open "" 22
Status: Connected to
Error:  Connection closed by server with exitcode 127
Error:  Could not connect to server

FileZilla converted the .pem to .ppk format. The permissions on the .pem are 600. The permissions on the .ppk are 700.

I can connect to a different server that shares the same key in CyberDuck. It's just this specific server which is giving me trouble. I've connected to this server successfully in the past using WinSCP on Windows, but I'm on a Mac now.

I've tried configuring CyberDuck to use SCP instead of SFTP, but I'm still getting the same error.

Is there something I need to change about the server configuration?

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.