Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is a weird one. For some reason, last night my mouse partially stopped working. Movement is fine, but the mouse buttons don't work. Mainly it's the left button, but occasionally the right click and scroll-wheel fail too.

Initially I thought it could be the mouse itself (the left button seemed to get a bit "soft" recently), but I tried another mouse and had the same issue. Both are USB wireless optical mice. The keyboard is working okay 95%, only problem is Alt+Tab doesn't seem to work. Both keys work fine independently.

At the time it happened I was using Chrome, I dragged to scrollbar to scroll and when I released the mouse it was still holding scrollbar.

I'm using Ubuntu 9.10, I upgraded weeks ago and everything was working fine so I don't think it's related to that. I also hadn't run any updates (I have now just in case something fixed it). But no luck.

Any ideas?

share|improve this question

8 Answers 8

Got this one too. The odd thing is, it doesn't take clicks from my mouse, but it fully recognizes my touchpad.

Anyway, opening a terminal and typing:

metacity --replace

will make it work if you're using compiz. If you want compiz back, type:

compiz --replace

and the mouse will work again.

It's easier getting to the terminal if you have Gnome-Do or if you assign a hotkey to it (like the super/windows key or tilde (~).

share|improve this answer
5  
If you stop the metacity --replace command, you'll be in a worse position than when you started, with even less functionality working. As a warning to others, don't stop the metacity process once started. I found this out the hard way. –  Dennis Oct 18 '11 at 10:29
    
@Dennis the compiz --replace should solve most of those issues. gnome-panel --replace might help others. XFCE has a similar option if I am not mistaken. –  matchew Oct 10 '12 at 14:57
    
if it is not possible to do anything in your current environment you can login to another console: [CTRL]+[ALT]+[6] and killall compiz start it with compiz --replace --display :0 go back with [CTRL]+[ALT]+[7] and restart compiz with compiz --replace &; in a console. did the job for me –  syss Sep 10 at 13:20
    
Better to run the command from Alt+F2 if that works, so you don't have to worry about closing the terminal. –  Nick Oct 6 at 9:53
    
And for newer versions: unity --replace –  jmiserez Oct 6 at 10:43

For what it's worth, I went into the package manager and searched for, 'mouse'. After that, I clicked on all the already installed applications (there aren't that many) and reinstalled all of 'em. Then I searched for 'keyboard' and did the same thing. Not much change there, either. Finally, I searched for 'input' and found a file called, 'inputattach'. Reinstalled it and my mouse problems are solved. Works like it did on the day I installed 10.04. It's so nice to have a mouse that behaves itself and works like it should, again.

I'm a relatively new Ubuntu user, but instead of asking a lot of questions and then waiting for someone to reply, I decided to try and do something about it on my own, and solved my mouse problems (computer mouse, that is...;)

What the file re-installation cleared up, was the need to click several times to open up a folder, having to hold the button down for sometimes as long as three or four seconds before the click would be activated, or having to right click to open a folder or open a file with a particular application.

Just wanted to share this with you since the 'input' of my mouse now seems to once again, be completely and fully 'attached' to my computer.

share|improve this answer
    
I had the same exact problem described here, <kbd>alt</kbd><kbd>tab</kbd> plus mouse functions frozen (not only clicks are not working but also the shape of the mouse is not changing and they where always unfrozen after <kbd>Ctrl</kbd><kbd>Q</kbd> over firefox and then <kbd>Alt</kbd><kbd>F1</kbd> over the desktop to activate menus). I just reinstalled the inputattach package, as @Cubby described and the problems stopped. –  user67774 Feb 16 '11 at 2:49
1  
Upvoted for solving your own problem, and sharing the solution with others. –  Jake Jul 13 '11 at 18:20
up vote 4 down vote accepted

I found that this was just a problem with the mouse. The left button has pretty much stopped working. Other buttons seemed to stop working because the left button gets "jammed". After restarting with the other mouse plugged in, it worked fine.

Damn, I seem to have gone through so many mice and/or keyboards recently...

share|improve this answer
1  
ha! sadly, hardware problems like this are never the first thing we think of. it must be the software, mice don't go bad... :) –  quack quixote Dec 10 '09 at 1:58

From the bug mentioned by Joe above (emphasis mine):

So here the bug and workarounds.

For example on youtube, whilst it recognises my mouse moving over various buttons, actual mouse clicks are not recognised. I can navigate using 'tab' but this is very painful. I can also right click. The problem doesn't occur with other flash players, e.g. swfdec-mozilla.

WORKAROUND 1: Disable compiz
WORKAROUND 2: Remove flashplugin-nonfree / flashplugin-installer and install from adobe
WORKAROUND 3: Open a terminal and enter:

   gksudo gedit /usr/lib/nspluginwrapper/i386/linux/npviewer

Then add: export GDK_NATIVE_WINDOWS=1 before the last line of text.

Note: The only workaround for Chrome/Chromium users is to disable compiz.

share|improve this answer

Mostly this may be reason :

The bug is well known. Look for example here:

Bug Link

A common workaround is exporting GDK_NATIVE_WINDOWS=1 before running the application with click problems.

(source)

share|improve this answer

It would happen to my ubuntu 10.04 every now and then too, and it only worked again after I clicked the touchpad button. However, it has never happened again ever since I changed my touchpad setting. I deactivated the tap-click of my touchpad, and now the "real" mouse never stalls.

share|improve this answer

I've had, perhaps a similar issue, thought I would chime in on what I did that seems to have worked. BTW, I'm using a wireless Logitech trackball on Ubuntu 10.04.

My issue was that the left button on my Logitech wireless trackball mouse would give me lots of problems. Sometimes it would be severe, sometimes barely noticeable. Clicking would sometimes register as a left click, sometimes register as a double click, and many, many times it would fail to register at all. Dragging and dropping and copy and paste became almost impossible. I could almost never manage to highlight text. In short, life with this mouse became unbearable. This problem affected all programs and windows.

I assumed the problem was with the mouse, even though I've only had it since June or July this year (2010). I focused my efforts on trying to fix the mouse. In the end, I essentially gimped up this mouse trying to make it work, but to no avail.

Finally, I stopped using the mouse completely, and switched to a wired trackball that had never previously given me any problems before. However, after using the wired mouse for a few days, I started to notice that it was having the exact same problem. So, then I realized that in all likelihood, this is a problem with 10.04.

After looking around online for some time trying to come across a solution that worked for me, I stumbled across the post above about using metacity --replace. So, based on that, I was pretty certain that Compiz was the root of my mouse issues. After playing around with Ubuntu Tweak, one of the menu options, "Enable Metacity's compositing feature", mentioned that I had to manually disable visual effects in appearance.

So, after disabling Visual Effects (System>Preferences>Appearance>Visual Effects then select None), the mouse is suddenly working again. I don't know if this will be a permanent solution or if it will start giving me problems again, but I thought I'd mention this solution.

share|improve this answer

Did not have any mouse issues until a recent update manager update. Suspected my wireless mouse, but had the same effects with a regular wired mouse: left mouse button would work on and off.

Reinstalling the xorg mouse input drivers which were already installed by default (xserver-xorg-input-mouse, xserver-xorg-input-evdev) did not change anything, but, seeing how many mouse drivers were installed by default made me wonder: will I ever use a Synaptics Touchpad on this desktop? I realized this is not Gentoo, and, many unnecessary drivers are installed by default to Ubuntu work across a wide hardware spectrum.

What solved my issue was to uninstall all xorg mouse drivers for devices which were very unlikely to ever be connected to my system. As soon as the superfluous drivers were uninstalled, my mouse clicks were back to normal.

I would also like to add that I have never needed the workaround mentioned above, i.e. setting the GDK_xxxxx environment variable. I have been running Compiz and Chrome on this system without ever needing this workaround. The only application that does not appear to like the mouse in conjunction with Compiz is Blender3d.....mouse clicks in this application are off by some 20 pixels vertically.

share|improve this answer

protected by nhinkle May 24 '11 at 0:43

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.