Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I plug in my USB Keyboard (Microsoft Comfort Curve 2000), an "Unknown device" shows up in Device Manager:

click to see the screenshot

Occassionaly the keyboard is showed correctly as "Comfort Curve 2000" but still with this yellow triangle. When I uninstall "unknown device" and plug in keyboard, this shows up:

click to see the screenshot #2

The keyboard was working perfectly before 15 February. During 15-24 February period I didn't use it at all, and today (25 February) it doesn't work. During this time I installed drivers to pciexpress usb 3.0 and a couple of windows updates. I uninstalled them both, but still no luck.

The keyboard works both in BIOS and other computers, so both USB port and the keyboard are fine. I once managed to use it in Windows after restart (not sure how) but it stopped working after a couple of minutes (perhaps it tried to find "better" drivers?).

I don't care if it'll be recognized as Microsoft Keyboard, generic USB keyboard driver would be just fine, but choosing it from drivers list doesn't help.

I tried to remove all keyboard-related devices from Device manager and rebooting.

How would you go about it? Note: I don't have any restore points.

share|improve this question

1 Answer 1

Try un-installing the driver for the keyboard and re-installing them manually. You should be able to find the driver on Microsoft's website. By doing this, you're basically doing a full reset, so if this doesn't work, it may mean that the keyboard or USB port is faulty.

share|improve this answer
    
How do I uninstall the driver? If you mean: to remove any Microsoft-keyboard-related software and click "uninstall" on partially-recognized device in Device Manager, this doesn't help. As I said, the keyboard is working perfectly before Windows boot, so it's a software issue. –  Matt Feb 25 at 13:00
    
That is correct, and you need to install the corresponding driver too. –  brian724080 Feb 26 at 6:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.