Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I think this is the best place to put this question, but I'm not sure. Basically, my computer will run very slow every once in a while but then everything goes back to normal (for example, I will type something into google and it will show only one character every 2 seconds or so and then finally catch up all at once and goes back to normal).

I notice that this happens when I am doing hard drive intensive things, but I don't know why that would happen so I am concerned. I point out that my computer is very powerful to show that it is not a CPU/RAM issue (intel core i7 quad core, 20 GB RAM, 2x1TB 5400 rpm HDDs).

One reason I am thinking it might not just be hard drive is that right now I am untarring a large file (~130 GB) on a drive that my OS is not installed on and I still see it happening with my OS.

I have done scans on my hard drive and it came back clean. I am running Windows 8.0 if it matters.

Any ideas how I can pinpoint this problem? It is very annoying when I am trying to program and seems like it could potentially be problematic.

share|improve this question
    
resmon.exe (windows resource monitor) can tell you the disk usage un %. if == 100%, then it may be your bottleneck. As adviced above, use an SSD for caching/installing system. or 7200rpm disks. (Also WHY 20Go memory ?) –  Kwaio Feb 26 at 10:21
    
I run a virtual machine which needs a lot of RAM as well. Honestly 20 isn't even enough most of the time! –  Laurbert515 Feb 26 at 15:24
    
From my experience, virtual machines tend to do eccessive i/o, especially if you don't disable swap mechanisms in guest OS. with 5400rpm disks, that becomes critical. –  Kwaio Feb 26 at 15:29
    
Thanks. I have a resource monitor and it definitely shows massive usage on the HDD. what confuses me is that even if my non-OS HD is being used, my OS will slow. Why would that be? –  Laurbert515 Feb 26 at 15:50

1 Answer 1

up vote 1 down vote accepted

Can you paste an output of Windows System Experience Index?

I would bet that hard drives are your bottleneck. Generally, your hardware is strong, but you should buy and SSD for your system drive, and install OS on it, since 5400 are slower disks. 12 GB SSD which you will use for system installation, will take you down about 100 euros, which is not all that bad.

At home, a have a desktop computer which I use as NAS, attached to 1Gbit lan network. When I copy the file to 5400 disk that I have, whole system slows down, even mouse movement become jugged.

To test if disks are really an issue, start copy operation from one disk to another. Find a large file (some that will take about 10-15 min to copy). Or even better, go with MOVE operation, and see if that slows down your system. I'd bet it will.

Let me know what you think.

share|improve this answer
    
Thanks. If I get a SSD how can I move my OS onto it? My windows key is embedded in my firmware so I can't simply reinstall the disk. –  Laurbert515 Feb 26 at 15:25
    
There are ways to retrieve your embedded key via some software but that's another topic. –  Kwaio Feb 26 at 15:30
    
If your system partition can fit on your 128gb ssd disk then you can just clone it and keep working. I just did that a month ago on my dell xps and windows 7 and everything went smoothly. –  DKasipovic Feb 26 at 20:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.