Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to get 'Metatrader4' running on a Ubuntu Jaunty Server box.

Wine latest is installed 1.1.32 / OpenBox / xorg minimal.

I get the application launch but don't see the icons (see related bug http://bugs.winehq.org/show_bug.cgi?id=6911).

I'm connecting to the server using VNC (vnc4server).

See error display below:

No icons showing

share|improve this question
    
Do you have the Xrender extension loaded in your x11 config file? –  Michael Graff Nov 17 '09 at 13:05
    
Well, i don't have a 'xorg.conf', it's a server without a monitor; i'm actually connecting to the box using VNC (vnc4server to be precise) I just installed xorg-core minimal and openbox as window manager, my goal is to limit memory thus i can't afford having a full gnome environement running. libxrender1 is installed (1:0.9.4-2). –  Disco Nov 17 '09 at 13:32
    
Oh forgot to mention it's running in a virtualmachine, thus no graphic card driver. –  Disco Nov 17 '09 at 13:42
add comment

migrated from serverfault.com Nov 18 '09 at 16:01

This question came from our site for professional system and network administrators.

2 Answers

up vote 3 down vote accepted

It doesn't look like you have XRender running on your X11 server - hence wine's complaints about not being able to alpha blend without XRender. Are you using the VNC X server or you're running an X locally on the virtualized graphics card and connecting to it using VNC screen scraping?

If its the former, then the answer is that vncserver (aka Xvnc) by default does not load XRender. Because of the way that vncserver is configured (i.e. not at all), then all extensions that are used are compile in. If you want XRender (and I believe its a must of you want to run wine), then you have two options - either recompile Xvnc with XRender, or use another server - I recommend using vnc4server which is a VNC extension to the standard X.org X11 server - you run a standard X server with the vnc extension loaded so you can load any other extension in the X11 standard configuration file (which normally includes XRender).

share|improve this answer
    
Hit, right.I don't know if xrender is actually running; is there a way to check this ? Regarding your options, i'm already using vnc4server. Question is : how to load the vnc extension in X11 ? Something to put in xorg.conf ? When i run glxinfo in vnc term; i get error saying 'glx extension missing on display :...' i don't know if it's related to this as it was suggested on winehq bugreport. –  Disco Nov 17 '09 at 15:59
    
For information here's my vnc launching script : /usr/bin/vnc4server :4000 -rfbauth /home/someuser/.vnc/passwd -rfbport 4000 -geometry 1024x768 -depth 24 -alwaysshared -fp /usr/share/fonts/X11/misc -extension XFIXES -desktop myVPS –  Disco Nov 17 '09 at 16:03
    
cannot find an 'opensource' vnc server that could have xrender, any ideas ? –  Disco Nov 17 '09 at 16:56
    
your use of the vnc4server doesn't look correct - you pass Xvnc command options to vnc4server which doesn't use them. I suggest running Xvnc directly with the options you need, and also try to add the option +extension RENDER to force it to load the XRENDER extension. Try to see if this works for you. –  Guss Nov 18 '09 at 9:24
add comment

There is no window manager running, furthermore I would suggest maybe if this is very important to you (I am guessing this from the fact that your desperate for help) you should maybe run this in windows?

The fact that wine is throwing a FIXME: is your answer... the code hasn't been developed yet.

Is this server related bar being installed on Ubuntu Server?

share|improve this answer
1  
Well, the key point is to have it run under linux, otherwise i'll just quit my job right away. Not sure to understand what you mean by 'server related bar' ? –  Disco Nov 17 '09 at 13:19
    
Last I check Metatrader was a Forex trading platform, and has very little to do with Servers & System Administration. Regarding 'server related bar' = Has this got anything to do with System administration? –  Crankyadmin Nov 17 '09 at 13:23
    
Of course, it's a wine/xorg related problem. –  Disco Nov 17 '09 at 13:33
    
Try superuser then... –  Crankyadmin Nov 17 '09 at 13:59
    
I'm not sure if superuser is the right place to fine Linux enthusiasts, especially as this might be related to the virtual machine. –  Guss Nov 17 '09 at 14:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.