Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem is as follows. I have two internet lines at my workplace. Both lead to two different routers. I have placed both routers on a switch via their lan ports and connected all wired computers to the switch.

The first router has a gateway address of 192.168.1.1 The second router has a gateway address of 192.168.1.254

I have enabled both devices to use DHCP servers with the first device having a range of 192.168.1.11 - 192.168.1.125 and the other to have a range of 192.168.1.126 - 192.168.1.253

All my wired computers are assigned static ip addresses on the first gateway with ip ranges from 192.168.1.2 - 192.168.1.10 (these are 9 computers)

I expect all the rest of the devices to connect as follows.

Devices connected wirelessly to router A get a default gateway ip of 192.168.1.1 and a DHCP ip from the range of 192.168.1.11 - 192.168.1.125

Devices connected wirelessly to router B get a default gateway ip of 192.168.1.254 and a DHCP ip from the range of 192.168.1.126 - 192.168.1.253

What happens though is that I connect my phone to SSID of router B and get a default gateway ip of 192.168.1.1 (which is the ip of router A) and an ip of 192.168.1.2 (which is an ip outside of the DHCP range of both routers)

I have really limited knowledge of networks and that is why my architecture might be bad. Any suggestions?

share|improve this question
add comment

1 Answer 1

As far as I know:

  1. router maybe has one DHCP server;

  2. DHCP server maybe has one zone.

I think you doing all right. By the way your phone connects to router A.

share|improve this answer
    
I know it connects to router A. That's what I wrote. For some reason the DHCP server of router A is "stealing" devices from router B because what I saw from my macbook was that after I was connected to the SSID of router B I would get the correct IPs from router B for 1 second and then it changed back to the IPs of router A. I disabled the DHCP server of router A for the time being. I don't know hwhat else to do. –  user2983285 Feb 27 at 15:33
    
Can you set "authoritative" flag on router B? –  eremelis Feb 27 at 16:21
    
I don't see an option like that. –  user2983285 Mar 4 at 18:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.