Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 8.1 inside VMWare Fusion 6. I have two screens:

  1. Macbook Pro Retina aka MBPr (15", 220 ppi)
  2. External HDMI monitor (24", 96 ppi)

VMWare Fusion IS indeed allowing me to use the native resolution of the Macbook Pro panel (i.e. 2880x1800) but in that mode my Desktop UI is all messed up. It's either too tiny for the Macbook Pro screen or too large for the external display.

I was under the impression that Windows 8.1 allows for per-monitor DPI? How can I set it up so that I have

  1. My Macbook Pro running at it's sharpest setting without making it too small AND
  2. My external display showing it's contents without blowing it up too big?

I know it's discussed in older OS's but since they are exactly that - older OS's, please don't consider this is as duplicate in any way.

share|improve this question
    
This is a confirmed issue with VMWare Fusion. Their support and engineering staff is aware of this issue - no idea when they will be releasing a patch. –  DeepSpace101 Apr 29 at 22:04

2 Answers 2

Upgrading to VMware Fusion 7 fix's the problem. It came out a few days ago.

share|improve this answer
    
How did you manage to make it work? I'm using Fusion 7 and I can't figure out the display setting combination to make it happen. When I change the monitor-specific DPI setting in Windows it still affects all 3 displays :/ –  enriquein Sep 15 at 12:57
1  
Thanks. But it's like VMWare asking $60 to fix a 2 year old bug that shouldn't have been there to begin with. What should have been a free bug fix is now advertised as a "brand new feature". /shady –  DeepSpace101 Sep 17 at 15:01
    
OK, so I'm not sure what I had working a few weeks back because I can't replicate it now. The closest I can get is by turning "Use full resolution for Retina display" off, which works, but makes everything pixalated on the laptop screen. –  Mint Sep 29 at 20:33

Right-click the Windows desktop background and select Screen resolution. Click the “Make text and other items larger or smaller” link in the Screen resolution window and you’ll be able to set a custom scaling level for your display.

If you choose the text box for "Let me choose scaling level for all my displays" you can manually adjust the scaling to fit your settings.

REF: http://www.howtogeek.com/175664/how-to-make-the-windows-desktop-work-well-on-high-dpi-displays-and-fix-blurry-fonts/

share|improve this answer
    
Have you tried it? It doesn't work - both with or without the "Let me choose one scaling level for all my displays". Note that I need it run both my displays simultaneously. What I see is exactly my original issue i.e. both displays tuned to either low DPI or high DPI - not to DPIs optimal for each. –  DeepSpace101 Feb 27 at 18:00
    
I've emailed VMWare support incase this is a VMWare issue too. I'm on VMWare Fusion 6.0.2 - will post back if something works. –  DeepSpace101 Feb 27 at 18:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.