Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to unsubscribe from certain folders that show up in Mail.app. But "right clicking on the account > Get Account Info > Subscription List" is always empty. Is there something I am doing wrong? There are a bunch of folders setup in the IMAP. The IMAP is hosted at dreamhost.com

What can I do?

share|improve this question
add comment

2 Answers

Check your IMAP path.... Preferences --> Accounts --> Account Name --> Advanced --> IMAP PATH PREFIX.

Check to see if Thunderbird has a setting for it, and using that instead of the default of "". If you find it in thunderbird, try changing it to that... Otherwise, Try removing that, and saving the changes...

Mail will probably re-sync, but you should then see your mail, and subscribed folders.

It may also be that MAIL.app doesn't fully support IMAP subscriptions...

See http://discussions.apple.com/message.jspa?messageID=7122662


After reading the discussion thread further, and exploring a little here myself... I believe that the Subscription List is only really enabled for Exchange Servers.

My Gmail accounts show blank subscription lists... But my exchange (work) account shows the public folders from the Exchange Server.... So that leads me to believe that this feature is really intended for exchange support...

share|improve this answer
    
I had 'INBOX' as the prefix. Tried after deleting it, but still the subscription list is empty. –  Shoan Nov 19 '09 at 8:26
add comment

If you are using Cyrus IMAP it has INBOX as a IMAP prefix for all user. INBOX = user.foo where user is the TOP level for all IMAP. If you remove this from the advanced settings in Mail.app it will correctly show all the Subscriptions but it will NOT show the users inbox correctly.

Use the INBOX as the root, all mail is correct but none of the top level subscriptions will show. It looks like Mail.App is busted, since Thunderbird seems to work fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.