Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was using normally some of my FTP accounts, and tried some ways to upload files via command line.

I based myself on this answer and something just like this question, apparently I couldn't make them work. The first because I new to the powershell and on the second one because I didn't know how to specify a path. (tried only ftp://server.tld/desired/path)

I didn't have much time, and didn't stress myself making it work. After that I got some problems when connecting to my server.

WinSCP give me this error if I on the Local Connection (Cable)

Transfer channel can't be opened. Reason: No connection could be made because the target machine actively refused it. Could not retrieve directory listing

Entering Passive Mode ( * , * , * , * ,67,102)

And this, when I connect with the wireless WPA2-Enterprise

Timeout detected. Could not retrieve directory listing

TYPE is now ASCII

Error listing directory '/'.

FileZilla just give me

Connection timed out. Failed to retrieve directory listing.

I've tried Passive and Active connection, selecting an specific path, rechecked firewall permissions, and nothing...

This only happens with my server, any other FTP connection works fine.

But I am not really sure what started this problem.

share|improve this question

1 Answer 1

If both your client and server are on an internal network with private IP addresses, and you try to access the server with your public NAT IP address, chances are that your firewall/router won't let you talk to/from the inside on the outside address.

After you have double-checked the routing and all involved firewalls, including software ones, you could try restarting the FTP service on the problematic server. It is very rare, but I've seen FTP server processes hang.

You could also try to access the server from the server itself. (Using "localhost" instead of the hostname or IP address of the server).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.