Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know speed is likely to be slower over Wi-Fi than ethernet. This is about the consistency or persistence of the connection itself. When I'm plugged into gigabit ethernet, I get a great connection, usually over the speed I pay for with my ISP and < 1% packet loss in an extended (several hours) ping test. When I connect over Wi-Fi, I have tons of trouble with the connection. Skype calls drop and reconnect repeatedly. (Nevermind the jokes about Skype. It happens with FaceTime and others as well.) Connection to our company chat drops. IM programs log out and back in over and over, causing me to miss important messages. And when I do ping tests, I get average ping times over 2 seconds (One run near 8 seconds), with maximums of around 20 seconds.

What could be causing this? Thanks in advance for any guidance you can offer.

Here are details about my setup:

  • Cable ISP paying for 30Mbps of service
  • Motorola Surfboard cable modem with DOCSIS 3.0 connected to latest generation Airport Extreme Base Station. (Prior, a 2TB Time Capsule.)
  • AEBS connected with Cat 5e cable to 24 port ethernet switch.
  • All hardware is in my office closet, less than 15′ away from my computer
  • Time Capsule plugged into ethernet switch for Time Machine backups
  • A few other devices like a printer, TiVo, and AppleTV also connected to the switch.
  • 15″ Retina MacBook Pro (First generation, whenever that was. Year and a half ago?)

and things I've tried:

  • Replace Time Capsule with new AEBS. Time Capsule is about four years old so this was my first thought.
  • Disabled the separate 5Ghz network. Found that my machine was jumping between the two and causing some of the issue, but it persists.
  • Moved the AEBS out of the closet. Now there is nothing but air between my computer and the AEBS.
  • Time Capsule: Made sure to disable wireless network and put it in bridge mode.

Here's a gist of wireless results, which I will duplicate here:

--- google.com ping statistics ---
228 packets transmitted, 228 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 39.070/1937.931/19344.446/3880.397 ms



share|improve this question

3 Answers 3

up vote 1 down vote accepted

It could be that the wireless channel that you're using is being heavily used by someone else nearby.

Try using a Wifi analyzer to see what channel you're using, and its strength, and see if others are using that channel, or a nearby channel.

I use a free app on my Android phone: "Wifi Analyzer" by Kevin Yuan that works great, but there are probably others available that will work for you.

If you find someone else is using the same Wifi channel (or a nearby channel), you may find switching the channel for your wireless will improve your speed.

share|improve this answer
    
I'm reticent to say it's solved lest the RF gods smite me, but changing from channel 11, which a few other networks in my neighborhood were using, to channel 3 seems to have helped. Thanks! –  jxpx777 Feb 28 at 19:16
    
In the end, it seems the issue was that my machine was switching back and forth between 2.4GHz and 5GHz. I created a separate 5GHz SSID and made all my devices forget about the 2.4GHz one. I'm going to add some additional access points to increase the coverage. –  jxpx777 Mar 5 at 19:55

Well, considering you get great connection speeds when you are hardwired - that sort of tells you that its not your ISP that is causing the issue. If it were your ISP, your connection would suck wired or on WiFi.

Now that we have eliminated that, here is what I would try

  • Buy an external USB WiFi dongle for testing purposes. Perform the same set of tests you have been doing with your current adapter and compare. This will confirm or deny if your current wireless card is somehow defective. The fact that you mentioned that your current wireless adapter was jumping between two different networks makes me think that it very well could be your adapter that is the issue. I am assuming you are using some sort of Mac/Apple laptop based on the fact that you have an AEBS and time capsule. I would go to the following site to see if you are in warranty

  • Apple Warranty Serial Number Lookup

  • Make sure your drivers for your current wireless interface are up to date.

  • And finally, purchase a 2nd router (you can always return it if the tests do not show any improvement) and replace your current AEBS and perform the same tests you have tried with your current setup. If you end up buying a new adapter and a new router, be sure to try both devices at the same time and compare results.

I know AEBS is supposed to be top of the line, but there is always the possibility that there is some issue with the one you have purchased.

I would also stop looking at the time capsule as the potential issue. All of your issues (Skype disconnecting, company chat issues, face time issues) are not local services, they are internet facing. Since we have established that your connection speeds are good when wired via Ethernet, it has to be your wireless adapter in your mac or your AEBS (hopefully not though). Since your time capsule is hardwired on your local network - I would say its a safe bet to say it is not the culprit.

share|improve this answer
    
Thanks. Would be a bummer to have bought a lemon AEBS less than a month ago, but maybe… –  jxpx777 Feb 28 at 17:26
    
try getting a USB dongle first, I have a hunch that its the adapter and not your AEBS. Did you buy it new from Apple? could always bring it into an apple retail store and show them the issue. –  Richie086 Feb 28 at 17:37

I had a similar issue that boiled down to some sort of interaction between my ISP's tagging of QOS/WMM information and my router. The easy test is to either disable QOS/WMM tagging (for wireless n) or set it to Wireless G and see if the problem goes away.

Note that the WMM is a required part of the N spec (as far as I know), so this is just a test to see if this resolves your problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.