Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am facing a weird problem on my Macbook (Mavericks).

I'm serving some files over http.

When I try to get the files using wget:

  • it works perfectly using localhost or 127.0.0.1
  • it starts but get stuck when using my local ip

See illustration here. The first download from 'localhost' happens smoothly, the second from my local ip, starts but get stuck around 11% and seems to stall forever.

I tried serving the files using different techniques:

  • with MAMP
  • using node.js
  • ...

I always get this problem, irrelevant of the file being served or the server technique/port.

I'm no network expert but this is quite strange to me...

When I try different files, it the download always gets stuck around 66kbytes...

Any idea why this might happen ?

share|improve this question
    
I tried serving the files with npm http-server as well and get the same problem –  borck Mar 2 at 17:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.