Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using arch linux. I have a new microsoft wireless mouse which scrolls(with the middle scroll wheel) too fast. I don't use kde or gnome but openbox and sometimes xmonad. I want to know how I can slow the scrolling down. I have come across many kde fixes for this, but no general or xorg fix.

PS: I have a dual boot and with windows 8.1, it works perfectly.

share|improve this question
up vote 2 down vote accepted

Apparently this could have something to do with using it along with Windows.

Taken from the Ubuntu Forum you can try:

Unplug the mouse receiver from the usb and then plug it back in (while running ubuntu). Whamo blamo you're fixed.

Ubuntu Forum

Might work for you to, give it a try.

share|improve this answer
    
Thanks. It worked, but it is somehow not practical to remove and insert the receiver every time I boot the system. Do you know some permanent fix? – rangalo Mar 3 '14 at 18:20
1  
@rangalo | From what I gather booting a Windows OS changes configuration of your wireless device. If you boot into Ubuntu only it won't bother you, but change to Windows will require an unplug. I might mimic your setup and see if I can find a permanent solution for you. – Matthew Williams Mar 3 '14 at 18:54
    
Thanks. The windows partition is mainly for the family and pay-tv, so cannot really do away with it. – rangalo Mar 3 '14 at 19:21

Try adding this line in xorg.conf under the "InputDevice " section and "{your device name}" subsection:

Option  "VertScrollDelta" "{scrollspeed}"

where smaller values result in faster scrolling.

share|improve this answer
    
This didn't help. It didn't change anything in the scroll behavior. – rangalo Mar 3 '14 at 18:18

Just spreading the words.

Try resetmsmice, which will fix this problem, without having to unplug and replug the mouse receiver.

And there is a AUR package.

Many thanks to the author Paul F Richards, also the Ubuntu launchpad bug report

share|improve this answer

This is known bug with some Microsoft mice. It is not just quick scroll, if you try to turn scroll wheel very slow you can see that scroll has non-linear speed. Moreover bug persists only if you previously boot to MS Windows (and may be in some other cases). You can fix it by:

  • resetmsmice app
  • unplug & plug mouse receiver
  • resetmsmice kernel patch (can be found in tar.gz distribution of resetmsmice)
  • fix-ms-mouse-scroll kernel patch

All of this fixes are struggling with the same problem. fix-ms-mouse-scroll patch supports newer kernels and some new mice (at least Microsoft Sculpt Ergonomic Mouse) in compare to resetmsmice (on which it is based on).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .