Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Ubuntu 12.04 LTS, and I am trying to use SQLite3. After installation, I get

$ sqlite3

SQLite header and source version mismatch

2011-11-01 00:52:41 c7c6050ef060877ebe77b41d959e9df13f8c9b5e

2014-02-03 14:04:11 6c643e45c274e755dc5a1a65673df79261c774be

A way to fix this is by replacing libsqlite3.so.0 and libsqlite3.so.0.8.6 in /usr/lib/i386-linux-gnu: copying the version from /usr/local/lib, and overwriting the version in /usr/lib/i386-linux-gnu (remember to back both versions up!). This is following the solution at https://bbs.archlinux.org/viewtopic.php?id=138892. So Sqlite3 should now work.

However, I then find that when I try to open Skype I get

$ skype

skype: error while loading shared libraries: libsqlite3.so.0: wrong ELF class: ELFCLASS64

Which can be rescued by giving /usr/lib/i386-linux-gnu its old version of libsqlite3.so.0. So it seems I can't use SQLite3 and Skype at the same time. Can anyone help?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.