Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

using Mediawiki in VMware localhost on (virtual) OpenSuse computer (latest version of distro) in company domain. MediaWiki using sqlite database. I had long latency (slow response) in localhost and also in company's network, so I tried first advice found through Google:

in /etc/hosts change: localhost

to localhost

after restarting server, I cannot already access localhost of this computer (on other company's PC via internet browser, url address is ip address of computer with OpenSuse). Localy (on OpenSuseĀ“s) localhost works fine.

So, I tried to revert this change (removing :8080) and restart server again, but accessing issue is still there. Also tried /etc/init.d/network restart command.

share|improve this question
Firstly, make sure there is a tab between the IP address of and the name localhost. Secondly - if you run "ping localhost", does it resolve to –  Adam Thompson Mar 3 '14 at 10:35
Adam Thompson: yes, it it tab character between these two items (no spaces). And localhost is accessible on OpenSuse (also ping, yes resolving, but on another computer in company´s network now not. –  Jerry1 Mar 3 '14 at 10:55
I might be missing something here. On your OpenSuse computer, you can access the Mediawiki site by going to, but you can't access it from another computer by going to (assuming is the IP of the OpenSuse server)? –  Adam Thompson Mar 3 '14 at 11:19
in browser on OpenSuse (localy): - OK - unable to connect localhost - OK on another PC in company's network: - timeout - timeout Before changing etc/hosts file connection works! –  Jerry1 Mar 3 '14 at 11:23
So your OpenSuse server is listening on port 80, and not 8080. If you're running MediaWiki on Apache, check the listenaddress is set to the proper IP of the OpenSuse server, and not –  Adam Thompson Mar 3 '14 at 11:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.