Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am in Thailand, and my ISP is ToT, and I am using Windows.

When I do a nslookup for google.com, I get the following:

C:\Windows\System32>nslookup
DNS request timed out.
    timeout was 2 seconds.
Default Server:  UnKnown
Address:  8.8.8.8

> set querytype-soa
> google.com
Server:  UnKnown
Address:  8.8.8.8

Non-authoritative answer:
Name:    google.com
Addresses:  2404:6800:4001:805::1007
          118.174.25.178
          118.174.25.172
          118.174.25.163
          118.174.25.187
          118.174.25.183
          118.174.25.152
          118.174.25.177
          118.174.25.157
          118.174.25.168
          118.174.25.162
          118.174.25.182
          118.174.25.153
          118.174.25.158
          118.174.25.173
          118.174.25.148
          118.174.25.167

I see that these IP addresses belong to my ISP: http://118.174.25.177.ipaddress.com/#ipinfo

A look at my IPConfig shows that my DNS servers are set to Google (8.8.8.8 and 8.8.4.4) and the University of Washington (128.95.120.1)

C:\Windows\System32>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : jasons-work
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 14-DA-E9-E9-8C-9A
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::90fd:63af:fa41:c4%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 10.0.10.15(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Lease Obtained. . . . . . . . . . : Monday, March 3, 2014 10:53:28 AM
   Lease Expires . . . . . . . . . . : Sunday, March 23, 2014 12:07:51 PM
   Default Gateway . . . . . . . . . : 10.0.0.1
   DHCP Server . . . . . . . . . . . : 10.0.0.1
   DHCPv6 IAID . . . . . . . . . . . : 253025001
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-80-FE-47-14-DA-E9-E9-8C-9A
   DNS Servers . . . . . . . . . . . : 8.8.8.8
                                       8.8.4.4
                                       128.95.120.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{9F166031-E04C-443A-9EF0-66CFA35C6943}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fb:475:993a:49cb:1d76(Preferred)
   Link-local IPv6 Address . . . . . : fe80::475:993a:49cb:1d76%14(Preferred)
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled

So my ISP is somehow rewriting my DNS result for google.com? While some may think this is mallicious, I think it's probably just their incompetence. (my requests to anything *.google.com return back network timeouts)

I don't have any custom software from my ISP installed, and I do have current antivirus up-to-date.

How can I circumvent this rewriting of my DNS entries?

I disabled IPv6 in my ethernet adapter, that had no impact. (i did ipconfig flushdns/renew afterwards)

EDIT: In the whois registrant data for http://118.174.25.177.ipaddress.com/#ipinfo , I see the text "IP Assignment for Google Caching Systems". So indeed it seems to confirm my ISP trying to cache google and screwing up. The question of how to circumvent this still stands.

share|improve this question
add comment

2 Answers 2

I think you are just not driving nslookup correctly. Firstly, set querytype-soa should have given you an error. If you really meant set querytype=soa, then you would be asking for Start Of Authority records and not Address records, so you definitely would not have gotten the response you show.

That said, the answer you got looks right for the part of the world you are in (Thailand). Google has web-farms spread all over the world to handle the load. There are even several in different parts of the United States.

share|improve this answer
    
i know that google uses it's own cdn network, but I'd assume that they would show whois ownership by google, not by my ISP. i'll do another test with the fixes you suggest. –  JasonS Mar 6 at 3:20
    
ahhh, it gets even better. i see my ISP is blocking DNS queries to other DNS servers, other than google (and I presume the ISP's own dns server, which i don't know the address). maybe they have some agreement with google and are having technical dificulties. anyway, seems DnsCrypt is still the way to go. –  JasonS Mar 6 at 3:49
add comment

I downloaded DnsCrypt and the gui interface for it, and that solves my problem.

I'll leave the question open for if anyone else has a better, less invasive solution.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.